diff configure.ac @ 18432:c71cbbae9443 stable

avoid substituting shell variable references in mkoctfile.cc * configure.ac: Avoid substituting '$BINDIR', '$OCTAVE_VERSION', and '$EXEEXT' into mkoctfile.cc on OS X systems.
author John W. Eaton <jwe@octave.org>
date Tue, 04 Feb 2014 16:53:48 -0500
parents 97984c1c41f0
children 888cd8f62c67 85d31344fb23
line wrap: on
line diff
--- a/configure.ac	Tue Feb 04 21:16:11 2014 +0100
+++ b/configure.ac	Tue Feb 04 16:53:48 2014 -0500
@@ -1662,7 +1662,7 @@
   ;;
   *-*-darwin*)
     DL_LDFLAGS='-bundle -bundle_loader $(top_builddir)/libinterp/octave $(LDFLAGS)'
-    MKOCTFILE_DL_LDFLAGS='-bundle -bundle_loader $$BINDIR/octave-$$OCTAVE_VERSION$$EXEEXT'
+    MKOCTFILE_DL_LDFLAGS='-bundle -bundle_loader $(bindir)/octave-$(version)$(EXEEXT)'
     SH_LDFLAGS='-dynamiclib -single_module $(LDFLAGS)'
     case $canonical_host_type in
       powerpc-*)