diff configure.ac @ 9970:cc7ea6083774

configure.ac: use pthread flags and libs for tests
author John W. Eaton <jwe@octave.org>
date Fri, 11 Dec 2009 20:58:51 -0500
parents 55061c7c8d6e
children d36f8c473dff
line wrap: on
line diff
--- a/configure.ac	Fri Dec 11 11:40:19 2009 -0800
+++ b/configure.ac	Fri Dec 11 20:58:51 2009 -0500
@@ -277,6 +277,10 @@
 AC_SUBST(DEPEND_EXTRA_SED_PATTERN)
 
 ACX_PTHREAD
+### Include pthread libs and flags here in case other tests need them.
+### They seem to be required for the OpenGL tests on Debian systems.
+LIBS="$PTHREAD_LIBS $LIBS"
+CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
 
 AC_PATH_X
 if test "$have_x" = "yes"; then