diff configure.in @ 9172:cd68431b395a

configure.in: shared library fixes for AIX and HPUX
author Peter O'Gorman <pogma@thewrittenword.com>
date Mon, 04 May 2009 15:47:05 -0400
parents 7500cfff4728
children 224634b2e6e3
line wrap: on
line diff
--- a/configure.in	Mon May 04 15:41:28 2009 -0400
+++ b/configure.in	Mon May 04 15:47:05 2009 -0400
@@ -1316,6 +1316,7 @@
     CPICFLAG=
     CXXPICFLAG=
     FPICFLAG=
+    library_path_var=LIBPATH
   ;;
   hppa*-hp-hpux*)
     if test "$ac_cv_f77_compiler_gnu" = yes; then
@@ -1326,6 +1327,16 @@
     SHLEXT=sl
     SH_LDFLAGS="-shared -fPIC"
     RLD_FLAG='-Wl,+b -Wl,$(octlibdir)'
+    library_path_var=SHLIB_PATH
+  ;;
+  ia64*-hp-hpux*)
+    if test "$ac_cv_f77_compiler_gnu" = yes; then
+      FPICFLAG=-fPIC
+    else
+      FPICFLAG=+Z
+    fi
+    SH_LDFLAGS="-shared -fPIC"
+    RLD_FLAG='-Wl,+b -Wl,$(octlibdir)'
   ;;
   *-sgi-*)
     CPICFLAG=