diff configure.ac @ 9799:cfd0aa788ae1

remove reference blas and lapack sources
author John W. Eaton <jwe@octave.org>
date Tue, 10 Nov 2009 23:07:25 -0500
parents 0d4613a736e9
children 13868ea67c71
line wrap: on
line diff
--- a/configure.ac	Tue Nov 10 19:48:02 2009 -0500
+++ b/configure.ac	Tue Nov 10 23:07:25 2009 -0500
@@ -904,16 +904,15 @@
 AC_SUBST(XTRA_CRUFT_SH_LDFLAGS)
 
 ### Checks for BLAS and LAPACK libraries:
-# (Build subdirectories of libcruft if they aren't found on the system.)
 ACX_BLAS_WITH_F77_FUNC([:], [:])
 ACX_LAPACK([:], [:])
 
-AM_CONDITIONAL([AMCOND_HAVE_BLAS], [test x$acx_blas_ok = xyes])
-AM_CONDITIONAL([AMCOND_HAVE_LAPACK], [test x$acx_lapack_ok = xyes])
+if test x$acx_blas_ok = xno || test x$acx_lapack_ok = xno; then
+  AC_MSG_ERROR([You are required to have BLAS and LAPACK libraries])
+fi
 
 if test "x$acx_blas_f77_func_ok" = "xno"; then
-  warn_blas_f77_incompatible="A BLAS library was detected but found incompatible with your Fortran 77 compiler.  The reference BLAS implementation will be used. To improve performance, consider using a different Fortran compiler or a switch like -ff2c to make your Fortran compiler use a calling convention compatible with the way your BLAS library was compiled, or use a different BLAS library."
-  AC_MSG_WARN($warn_blas_f77_incompatible)
+  AC_MSG_ERROR([A BLAS library was detected but found incompatible with your Fortran 77 compiler])
 fi
 
 # Check for the qrupdate library
@@ -2334,11 +2333,6 @@
   warn_msg_printed=true
 fi
 
-if test -n "$warn_blas_f77_incompatible"; then
-  AC_MSG_WARN($warn_blas_f77_incompatible)
-  warn_msg_printed=true
-fi
-
 if test -n "$warn_umfpack"; then
   AC_MSG_WARN($warn_umfpack)
   warn_msg_printed=true