diff configure.ac @ 18264:d033b08e9b0e stable

Detect and use appropriate terminal attribute functions (bug #41212) * configure.ac: Add AC_CHECK_FUNCS for tcgetattr and tcsetattr. * kpty.cpp (_tcgetattr, _tcsetattr): Define to the appropriate terminal attribute functions based on system library support, not OS type macros. Fixes build failures on non-Linux GNU-based systems. Based on a Debian patch to the kde4libs package.
author Mike Miller <mtmiller@ieee.org>
date Sun, 12 Jan 2014 17:51:47 -0500
parents b6b6e0dc700e
children 975480e1be4b
line wrap: on
line diff
--- a/configure.ac	Sun Jan 12 12:41:39 2014 +0100
+++ b/configure.ac	Sun Jan 12 17:51:47 2014 -0500
@@ -2186,7 +2186,7 @@
 AC_CHECK_FUNCS([log1p log1pf pipe])
 AC_CHECK_FUNCS([realpath resolvepath roundl])
 AC_CHECK_FUNCS([select setgrent setpwent siglongjmp strsignal])
-AC_CHECK_FUNCS([tempnam tgammaf toascii])
+AC_CHECK_FUNCS([tcgetattr tcsetattr tempnam tgammaf toascii])
 AC_CHECK_FUNCS([umask waitpid])
 AC_CHECK_FUNCS([_kbhit])