diff configure.ac @ 12195:d25dfa9ed18b

remove configure checks for ARPACK
author John W. Eaton <jwe@octave.org>
date Fri, 28 Jan 2011 14:05:09 -0500
parents 5913cc5fec4e
children e3048d7fb131
line wrap: on
line diff
--- a/configure.ac	Fri Jan 28 14:04:33 2011 -0500
+++ b/configure.ac	Fri Jan 28 14:05:09 2011 -0500
@@ -1107,15 +1107,6 @@
   LIBS="$save_LIBS"
 fi
 
-save_LIBS="$LIBS"
-LIBS="$LAPACK_LIBS $BLAS_LIBS $FLIBS $LIBS"
-OCTAVE_CHECK_LIBRARY(arpack, ARPACK,
-  [ARPACK not found.  The eigs function will be disabled.],
-  [],
-  [dseupd],
-  [Fortran 77], [don't use the ARPACK library, disable eigs function])
-LIBS="$save_LIBS"
-
 ### Enable dynamic linking.  --enable-shared implies this, so
 ### --enable-dl is only need if you are only building static libraries
 ### and want to try dynamic linking too (works on some systems, for
@@ -2079,7 +2070,6 @@
   AMD CPPFLAGS:                $AMD_CPPFLAGS
   AMD LDFLAGS:                 $AMD_LDFLAGS
   AMD libraries:               $AMD_LIBS
-  ARPACK libraries:            $ARPACK_LIBS
   BLAS libraries:              $BLAS_LIBS
   CAMD CPPFLAGS:               $CAMD_CPPFLAGS
   CAMD LDFLAGS:                $CAMD_LDFLAGS
@@ -2329,7 +2319,7 @@
   AC_MSG_WARN([Make.  This should work automatically for gfortran.  If])
   AC_MSG_WARN([you use another compiler, you will need to set this])
   AC_MSG_WARN([variable on the configure command line.  You must also])
-  AC_MSG_WARN([compile the ARPACK, BLAS, LAPACK, QRUPDATE, and SuiteSparse])
+  AC_MSG_WARN([compile the BLAS, LAPACK, QRUPDATE, and SuiteSparse])
   AC_MSG_WARN([libraries to use 8 byte signed integers for array indexing.])
   AC_MSG_WARN([])
   warn_msg_printed=true