diff configure.in @ 6276:d26c558691cd

[project @ 2007-02-07 09:01:24 by jwe]
author jwe
date Wed, 07 Feb 2007 09:01:24 +0000
parents 6fab59e81b4e
children c6a7b0453f9a
line wrap: on
line diff
--- a/configure.in	Wed Feb 07 07:29:47 2007 +0000
+++ b/configure.in	Wed Feb 07 09:01:24 2007 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.552 $)
+AC_REVISION($Revision: 1.553 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -527,6 +527,11 @@
   fi
 
   if $WITH_HDF5; then
+    case "$canonical_host_type" in
+      *-*-msdosmsvc)
+        OCTAVE_HDF5_DLL
+        ;;
+    esac
     true
   else
     warn_hdf5="HDF5 library not found.  Octave will not be able to save or load HDF5 data files."
@@ -1913,6 +1918,7 @@
 
 #if defined (_MSC_VER)
 #define __WIN32__
+#define WIN32
 /* missing parameters in macros */
 #pragma warning (disable: 4003)
 /* missing implementations in template instantiation */