diff configure.in @ 8771:d3382daaf4d2

Use CARBON_LIBS instead of LIBS for framework Carbon.
author Thomas Treichl <Thomas.Treichl@gmx.net>
date Tue, 17 Feb 2009 00:28:48 -0500
parents af676d09da08
children bbb3fa6778f3
line wrap: on
line diff
--- a/configure.in	Tue Feb 17 00:27:30 2009 -0500
+++ b/configure.in	Tue Feb 17 00:28:48 2009 -0500
@@ -283,8 +283,9 @@
   [have_framework_carbon="yes"], [have_framework_carbon="no"])
 if test $have_framework_carbon = "yes"; then
   AC_DEFINE(HAVE_FRAMEWORK_CARBON, 1, [Define if framework CARBON is available.])
-  LIBS="$LIBS -Wl,-framework -Wl,Carbon"
-  AC_MSG_NOTICE([adding -Wl,-framework -Wl,Carbon to LIBS])
+  CARBON_LIBS="-Wl,-framework -Wl,Carbon"
+  AC_MSG_NOTICE([adding -Wl,-framework -Wl,Carbon to CARBON_LIBS])
+  AC_SUBST(CARBON_LIBS)
 fi
 
 ### On Intel systems with gcc, we may need to compile with -mieee-fp
@@ -2133,6 +2134,7 @@
   FLTK backend libs:    $GRAPHICS_LIBS
   X11 include flags:    $X11_INCFLAGS
   X11 libraries:        $X11_LIBS
+  CARBON libraries:     $CARBON_LIBS
   LIBS:                 $LIBS
   Default pager:        $DEFAULT_PAGER
   gnuplot:              $GNUPLOT