diff configure.in @ 2488:d4eb39779b88

[project @ 1996-11-08 22:35:59 by jwe]
author jwe
date Fri, 08 Nov 1996 22:37:42 +0000
parents ccaffe93c32f
children f8d5dbbbc50a
line wrap: on
line diff
--- a/configure.in	Fri Nov 08 15:58:53 1996 +0000
+++ b/configure.in	Fri Nov 08 22:37:42 1996 +0000
@@ -18,9 +18,10 @@
 ### 
 ### You should have received a copy of the GNU General Public License
 ### along with Octave; see the file COPYING.  If not, write to the Free
-### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
+### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.229 $)
+AC_REVISION($Revision: 1.230 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -603,52 +604,6 @@
 AC_SUBST(F2CFLAGS)
 AC_SUBST_FILE(f77_rules_frag)
 
-### Extract libraries and directories from FLIBS and CXXLIBS.
-###
-### Leave only libraries, with -lfoo converted to libfoo.a:
-
-changequote(,)dnl
-FLIB_LIST=`echo " $FLIBS " | sed -e 's/ -Xlinker *[^ ]*/ /g' \
-	-e 's/ -[LR] *[^ ]*/ /g' \
-	-e 's/ -l *\([^ ]*\)/ lib\1.a/g' -e 's/ -u *[^ ]*/ /g' \
-	-e 's/ [^ ]*\.o//g' \
-	-e 's/^ *//' -e 's/ *$//' -e 's/  */:/g'`
-
-CXXLIB_LIST=`echo " $CXXLIBS " | sed -e 's/ -Xlinker *[^ ]*/ /g' \
-	-e 's/ -[LR] *[^ ]*/ /g' \
-	-e 's/ -l *\([^ ]*\)/ lib\1.a/g' -e 's/ -u *[^ ]*/ /g' \
-	-e 's/ [^ ]*\.o//g' \
-	-e 's/^ *//' -e 's/ *$//' -e 's/  */:/g'`
-
-### Leave only directories where libraries might be found:
-
-FLIB_PATH=`echo " $FLIBS " | sed \
-	-e 's/ /  /g' -e 's/ -Xlinker *[^ ]*/ /g' \
-	-e 's/ -[LR] *\([^ ]*\)/ \1/g' -e 's, /[^ ]*\.a , ,g' \
-	-e 's/ -l *[^ ]*/ /g' -e 's/ -u *[^ ]*/ /g' \
-	-e 's/ [^ ]*\.o//g' \
-	-e 's/^ *//' -e 's/ *$//' -e 's/  */:/g'`
-
-CXXLIB_PATH=`echo " $CXXLIBS " | sed -e 's/ -Xlinker *[^ ]*/ /g' \
-	-e 's/ -[LR] *\([^ ]*\)/ \1/g' -e 's, /[^ ]*\.a , ,g' \
-	-e 's/ /  /g' -e 's/ -Xlinker *[^ ]*/ /g' \
-	-e 's/ -l *[^ ]*/ /g' -e 's/ -u *[^ ]*/ /g' \
-	-e 's/ [^ ]*\.o//g' \
-	-e 's/^ *//' -e 's/ *$//' -e 's/  */:/g'`
-changequote([,])dnl
-
-AC_MSG_RESULT([defining FLIB_LIST to be $FLIB_LIST])
-AC_MSG_RESULT([defining FLIB_PATH to be $FLIB_PATH])
-
-AC_MSG_RESULT([defining CXXLIB_LIST to be $CXXLIB_LIST])
-AC_MSG_RESULT([defining CXXLIB_PATH to be $CXXLIB_PATH])
-
-AC_SUBST(FLIB_LIST)
-AC_SUBST(FLIB_PATH)
-
-AC_SUBST(CXXLIB_LIST)
-AC_SUBST(CXXLIB_PATH)
-
 ### Checks for header files.
 
 AC_HEADER_STDC
@@ -657,10 +612,10 @@
 AC_HEADER_SYS_WAIT
 
 AC_CHECK_HEADERS(assert.h curses.h fcntl.h float.h floatingpoint.h \
-  grp.h limits.h memory.h pwd.h sgtty.h stdlib.h string.h sys/param.h \
-  sys/resource.h sys/select.h sys/stat.h sys/time.h sys/times.h \
-  sys/types.h sys/utsname.h termcap.h termio.h termios.h unistd.h \
-  varargs.h)
+  grp.h limits.h memory.h ncurses.h pwd.h sgtty.h stdlib.h string.h \
+  sys/param.h sys/resource.h sys/select.h sys/stat.h sys/time.h \
+  sys/times.h sys/types.h sys/utsname.h termcap.h termio.h termios.h \
+  unistd.h varargs.h)
 
 if test "$ac_cv_header_termios_h" = yes \
     || test "$ac_cv_header_termio_h" = yes \
@@ -856,6 +811,16 @@
 done
 AC_SUBST(TERMLIBS)
 
+if test "$ac_cv_lib_termcap" = yes \
+    || test "$ac_cv_lib_terminfo" = yes \
+    || test "$ac_cv_lib_ncurses" = yes \
+    || test "$ac_cv_lib_curses" = yes \
+    || test "$ac_cv_lib_termlib" = yes; then
+  true
+else
+  AC_MSG_WARN([I couldn't find -ltermcap, -lterminfo, -lncurses, -lcurses, or -ltermlib!])
+fi
+
 AC_MSG_CHECKING([for struct exception in math.h])
 AC_TRY_LINK([#include <math.h>],
   [struct exception *x; x->type; x->name;],