diff configure.in @ 8595:dee5d60257e4

Use Carbon framework to determine ScreenSize on Mac.
author Thomas Treichl <Thomas.Treichl@gmx.net>
date Mon, 26 Jan 2009 23:07:09 -0500
parents ab61b47d3435
children 08331c2fb00f
line wrap: on
line diff
--- a/configure.in	Mon Jan 26 22:43:29 2009 -0500
+++ b/configure.in	Mon Jan 26 23:07:09 2009 -0500
@@ -270,6 +270,15 @@
   AC_SUBST(X11_LIBS)
 fi
 
+### On MacOSX system the Carbon framework is used to determine ScreenSize
+OCTAVE_HAVE_FRAMEWORK(Carbon, [#include <Carbon/Carbon.h>], [CGMainDisplayID ()],
+  [have_carbon="yes"], [have_carbon="no"])
+if test $have_carbon = "yes"; then
+  AC_DEFINE(HAVE_FRAMEWORK_CARBON, 1, [Define if framework CARBON is available.])
+  LDFLAGS="$LDFLAGS -Wl,-framework -Wl,Carbon"
+  AC_MSG_NOTICE([adding -Wl,-framework -Wl,Carbon to LDFLAGS])
+fi
+
 ### On Intel systems with gcc, we may need to compile with -mieee-fp
 ### and -ffloat-store to get full support for IEEE floating point.
 ###