diff libcruft/Makefile.am @ 9980:e352f8366b02

Use simple_move_if_change_rule for cruft.def to eliminate unnecessary compilations.
author Rik <rdrider0-list@yahoo.com>
date Sun, 13 Dec 2009 22:32:47 -0800
parents 8d20fb66a0dc
children e517da95bf98
line wrap: on
line diff
--- a/libcruft/Makefile.am	Sun Dec 13 20:01:16 2009 -0800
+++ b/libcruft/Makefile.am	Sun Dec 13 22:32:47 2009 -0800
@@ -23,9 +23,9 @@
 
 include ../common.mk
 
-octlib_LTLIBRARIES = libcruft.la
+AUTOMAKE_OPTIONS = subdir-objects
 
-AUTOMAKE_OPTIONS = subdir-objects
+octlib_LTLIBRARIES = libcruft.la
 
 libcruft_la_SOURCES =
 
@@ -60,7 +60,8 @@
 include slatec-fn/module.mk
 include villad/module.mk
 
-cruft.def: $(libcruft_la_SOURCES) $(TOPDIR)/libcruft/mkf77def
+cruft.def: $(libcruft_la_SOURCES) mkf77def
 	chmod a+rx mkf77def
 	./mkf77def $(srcdir) $(libcruft_la_SOURCES) > $@-t
-	mv $@-t $@
+	$(simple_move_if_change_rule)
+