diff libcruft/Makefile.am @ 10004:e517da95bf98

Eliminate TOPDIR variable in favor of built-in automake variables top_builddir and top_srcdir.
author Rik <rdrider0-list@yahoo.com>
date Sat, 19 Dec 2009 22:58:54 -0800
parents e352f8366b02
children f91d41387a05
line wrap: on
line diff
--- a/libcruft/Makefile.am	Sat Dec 19 14:24:02 2009 -0800
+++ b/libcruft/Makefile.am	Sat Dec 19 22:58:54 2009 -0800
@@ -19,9 +19,7 @@
 # along with Octave; see the file COPYING.  If not, see
 # <http://www.gnu.org/licenses/>.
 
-TOPDIR = ..
-
-include ../common.mk
+include $(top_srcdir)/common.mk
 
 AUTOMAKE_OPTIONS = subdir-objects
 
@@ -40,9 +38,7 @@
 
 octinclude_HEADERS =
 
-DISTCLEANFILES = cruft.def
-
-EXTRA_DIST = ChangeLog STOP.patch mkf77def.in
+EXTRA_DIST =
 
 include amos/module.mk
 include blas-xtra/module.mk
@@ -65,3 +61,7 @@
 	./mkf77def $(srcdir) $(libcruft_la_SOURCES) > $@-t
 	$(simple_move_if_change_rule)
 
+EXTRA_DIST += ChangeLog STOP.patch mkf77def.in
+
+DISTCLEANFILES = cruft.def
+