diff test/Makefile.am @ 10004:e517da95bf98

Eliminate TOPDIR variable in favor of built-in automake variables top_builddir and top_srcdir.
author Rik <rdrider0-list@yahoo.com>
date Sat, 19 Dec 2009 22:58:54 -0800
parents 5277222b47d1
children 655ab6f6c369
line wrap: on
line diff
--- a/test/Makefile.am	Sat Dec 19 14:24:02 2009 -0800
+++ b/test/Makefile.am	Sat Dec 19 22:58:54 2009 -0800
@@ -19,9 +19,7 @@
 # along with Octave; see the file COPYING.  If not, see
 # <http://www.gnu.org/licenses/>.
 
-TOPDIR = ..
-
-include ../common.mk
+include $(top_srcdir)/common.mk
 
 FCN_FILES = \
   fntests.m \
@@ -64,6 +62,12 @@
 include @Snork/module.mk
 include @Spork/module.mk
 
+check: test_sparse.m
+	$(top_builddir)/run-octave --norc --silent --no-history $(srcdir)/fntests.m $(srcdir)
+
+test_sparse.m: build_sparse_tests.sh
+	$(srcdir)/build_sparse_tests.sh
+
 EXTRA_DIST = \
   ChangeLog \
   build_sparse_tests.sh \
@@ -75,9 +79,3 @@
 DISTCLEANFILES = \
   fntests.log
 
-check: test_sparse.m
-	../run-octave --norc --silent --no-history $(srcdir)/fntests.m $(srcdir)
-
-test_sparse.m: build_sparse_tests.sh
-	$(srcdir)/build_sparse_tests.sh
-