diff test/Makefile.am @ 16603:e5c0acc31640

install .gdbinit in test directory * build-aux/common.mk (gdbinit_install_rule): New macro. * Makefile.am (.gdbinit): Use it. * test/Makefile.am (all-local, .gdbinit): New targets.
author John W. Eaton <jwe@octave.org>
date Fri, 03 May 2013 00:29:07 -0400
parents 11115c237231
children 5b6d8bfdea25
line wrap: on
line diff
--- a/test/Makefile.am	Fri May 03 00:27:55 2013 -0400
+++ b/test/Makefile.am	Fri May 03 00:29:07 2013 -0400
@@ -60,6 +60,11 @@
 include fcn-handle-derived-resolution/module.mk
 include nest/module.mk
 
+all-local: .gdbinit
+
+.gdbinit: ../etc/gdbinit
+	@$(gdbinit_install_rule)
+
 check: sparse.tst bc-overload-tests.stamp
 	$(top_builddir)/run-octave --norc --silent --no-history $(srcdir)/fntests.m $(srcdir)