diff test/Makefile.am @ 19647:e8e3a89fa370

Fix colormap functions when N is not of class double (bug #44070) * autumn.m, bone.m, cool.m, copper.m, cubehelix.m, gray.m, hsv.m, ocean.m, rainbow.m, spring.m, summer.m, winter.m: cast N to double since in this colormap functions, N is used directly used in the operations and ends up casting colormap to something else. Note that a colormap MUST be of class double. Also, if N is an integer class, all values in colormap end up 0 or 1. Also simplify code for input checking by declaring default on function signature line. * flag.m, gmap40.m, hot.m, jet.m, lines.m, pink.m, prism.m, white.m: simplify input check like the other colormap functions. * test/colormaps.tst: add new test file to test all colormaps at once. * test/Makefile.am: add new test file to build system. used to create the colormap and if less
author Carnë Draug <carandraug@octave.org>
date Fri, 23 Jan 2015 15:37:56 +0000
parents 0e1f5a750d00
children bdf90710dddf
line wrap: on
line diff
--- a/test/Makefile.am	Fri Jan 23 16:33:02 2015 +0000
+++ b/test/Makefile.am	Fri Jan 23 15:37:56 2015 +0000
@@ -25,6 +25,7 @@
   args.tst \
   bug-31371.tst \
   bug-38576.tst \
+ colormaps.tst \
   diag-perm.tst \
   error.tst \
   eval-catch.tst \