diff configure.in @ 4101:ea537559ab07

[project @ 2002-10-11 20:57:21 by jwe]
author jwe
date Fri, 11 Oct 2002 20:57:21 +0000
parents 8496ae60db8a
children cbac6756967e
line wrap: on
line diff
--- a/configure.in	Fri Oct 11 16:37:45 2002 +0000
+++ b/configure.in	Fri Oct 11 20:57:21 2002 +0000
@@ -22,7 +22,7 @@
 ### 02111-1307, USA. 
 
 AC_INIT
-AC_REVISION($Revision: 1.374 $)
+AC_REVISION($Revision: 1.375 $)
 AC_PREREQ(2.52)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -1288,6 +1288,20 @@
 #if !defined(HAVE_SIGSET_T)
 typedef int sigset_t;
 #endif
+
+#define OCTAVE_HAVE_POSIX_FILESYSTEM 1
+
+#if defined (__WIN32__)
+#define OCTAVE_HAVE_WINDOWS_FILESYSTEM 1
+#if ! defined (__CYGWIN__)
+#undef OCTAVE_HAVE_POSIX_FILESYSTEM
+#endif
+#endif
+
+/* Define if we expect to have <windows.h>, Sleep, etc. */
+#if defined (__WIN32__) || ! defined (__CYGWIN__)
+#define OCTAVE_USE_WINDOWS_API 1
+#endif
 ])
 
 ### Do the substitutions in all the Makefiles.