diff configure.in @ 7095:efd16513ff8f

[project @ 2007-11-01 17:37:21 by jwe]
author jwe
date Thu, 01 Nov 2007 17:37:21 +0000
parents 5608935ff522
children 373c39904877
line wrap: on
line diff
--- a/configure.in	Thu Nov 01 02:17:32 2007 +0000
+++ b/configure.in	Thu Nov 01 17:37:21 2007 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.589 $)
+AC_REVISION($Revision: 1.590 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -731,49 +731,6 @@
 AC_SUBST(BLAS_DIR)
 AC_SUBST(LAPACK_DIR)
 
-dnl I see no clean way to do the following check with autoconf macros,
-dnl hence the big mess.
-
-AC_MSG_CHECKING([BLAS library calling convention compatibility])
-cat << EOF > conftest.f
-      program foo
-      double complex zdotu, zx(10), zy(10), retval
-      integer n, incx, incy
-      n = 10
-      incx = 1
-      incy = 1
-      do 10 i = 1, n
-        zx(i) = dcmplx (i, 0)
-        zy(i) = dcmplx (0, i)
-   10 continue
-      retval = zdotu (n, zx, incx, zy, incy)
-      if (retval .eq. dcmplx (0, 385)) then
-        print *, 'succeeded'
-      else
-        print *, 'failed'
-        print *, retval
-      endif
-      end
-EOF
-XLIBS="$LIBS"
-LIBS="$BLAS_LIBS $FLIBS $LIBS"
-AC_LANG_PUSH(Fortran 77)
-(eval "$ac_compile"; eval "$ac_link") 2>&AS_MESSAGE_LOG_FD
-AC_LANG_POP(Fortran 77)
-LIBS="$XLIBS"
-case "`./conftest$ac_exeext`" in
-  *succeeded*)
-  AC_MSG_RESULT(yes)
-;;
-  *)
-  AC_MSG_RESULT(no)
-  AC_MSG_WARN([Your BLAS library was apparently compiled with a Fortran])
-  AC_MSG_WARN([compiler that uses a different calling convention from])
-  AC_MSG_WARN([the one used by the selected compiler, $F77.])
-  AC_MSG_ERROR([You must correct this problem before building Octave.])
-;;
-esac
-
 # Check for AMD library
 AMD_LIBS=
 AC_SUBST(AMD_LIBS)