diff libinterp/Makefile.am @ 15278:f4b5304ee451

build: Remove unnecessary -I includes from AM_CPPFLAGS. * libinterp/Makefile.am: Remove unnecessary -I includes from AM_CPPFLAGS. * src/Makefile.am: Remove unnecessary -I includes from AM_CPPFLAGS. * liboctave/Makefile.am: Use $top_builddir to make list more readable. * liboctave/cruft/Makefile.am: Replace tabs with spaces in file list. * liboctave/cruft/slatec-fn/module.mk: Add blank line at end of file.
author Rik <rik@octave.org>
date Sun, 02 Sep 2012 17:41:43 -0700
parents 648dabbb4c6b
children 03ef3a183129
line wrap: on
line diff
--- a/libinterp/Makefile.am	Sun Sep 02 15:57:56 2012 -0700
+++ b/libinterp/Makefile.am	Sun Sep 02 17:41:43 2012 -0700
@@ -25,12 +25,11 @@
 ## Search local directories before those specified by the user.
 AM_CPPFLAGS = \
   -I$(top_srcdir)/liboctave/cruft/misc \
-  -I../liboctave/array -I$(top_srcdir)/liboctave/array \
-  -I../liboctave/numeric -I$(top_srcdir)/liboctave/numeric \
-  -I../liboctave/operators -I$(top_srcdir)/liboctave/operators \
-  -I../liboctave/system -I$(top_srcdir)/liboctave/system \
-  -I../liboctave/util -I$(top_srcdir)/liboctave/util \
-  -I../liboctave -I$(top_srcdir)/liboctave \
+  -I$(top_srcdir)/liboctave/array \
+  -I$(top_builddir)/liboctave/numeric -I$(top_srcdir)/liboctave/numeric \
+  -I$(top_builddir)/liboctave/operators -I$(top_srcdir)/liboctave/operators \
+  -I$(top_srcdir)/liboctave/system \
+  -I$(top_srcdir)/liboctave/util \
   -I$(srcdir)/octave-value \
   -I$(srcdir)/operators \
   -Iparse-tree -I$(srcdir)/parse-tree \
@@ -170,7 +169,7 @@
   interp-core/libinterp-core.la \
   interpfcn/libinterpfcn.la \
   corefcn/libcorefcn.la \
-  ../liboctave/liboctave.la \
+  $(top_builddir)/liboctave/liboctave.la \
   $(LIBOCTINTERP_LINK_DEPS)
 
 # Increment these as needed and according to the rules in the libtool manual:
@@ -227,9 +226,10 @@
 ## Special rules:
 ## Mostly for sources which must be built before rest of compilation.
 
-## oct-conf.h must depend on Makefile.  Calling configure
-## may change default/config values.  However, calling configure will also
-## regenerate the Makefiles from Makefile.am and trigger the rules below.
+## oct-conf.h must depend on Makefile.
+## Calling configure may change default/config values.
+## However, calling configure will also regenerate the Makefiles from
+## Makefile.am and trigger the rules below.
 oct-conf.h: oct-conf.in.h Makefile
 	@$(do_subst_config_vals)