diff configure.in @ 3105:f936c7f5074f

[project @ 1997-11-19 04:36:17 by jwe]
author jwe
date Wed, 19 Nov 1997 04:37:56 +0000
parents e6d14959bea9
children a8dcfbf87ea3
line wrap: on
line diff
--- a/configure.in	Tue Nov 18 20:16:27 1997 +0000
+++ b/configure.in	Wed Nov 19 04:37:56 1997 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.285 $)
+AC_REVISION($Revision: 1.286 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -88,15 +88,18 @@
 ### specified (multiple "no" or --without-FOO options are ok).
 
 OCTAVE_CHECK_EXCLUSIVE_WITH_OPTIONS(f77, g77,
-  [AC_MSG_WARN([--with-f77 and --with-g77 both specified!  Using g77...])
+  [warn_f77_and_g77="--with-f77 and --with-g77 both specified!  Using g77..."
+  AC_MSG_WARN($warn_f77_and_g77)
   use_g77=false])
 
 OCTAVE_CHECK_EXCLUSIVE_WITH_OPTIONS(f77, f2c,
-  [AC_MSG_WARN([--with-f2c and --with-f77 both specified!  Using f77...])
+  [warn_f2c_and_f77="--with-f2c and --with-f77 both specified!  Using f77..."
+  AC_MSG_WARN($warn_f2c_and_f77)
   use_f2c=false])
 
 OCTAVE_CHECK_EXCLUSIVE_WITH_OPTIONS(g77, f2c,
-  [AC_MSG_WARN([--with-f2c and --with-g77 both specified!  Using g77...])
+  [warn_f2c_and_g77="--with-f2c and --with-g77 both specified!  Using g77..."
+  AC_MSG_WARN($warn_f2c_and_g77)
   use_f2c=false])
 
 ### Allow the user disable support for GNU info.
@@ -198,7 +201,8 @@
     AC_MSG_ERROR([g++ version $gxx_version will not work to compile Octave])
   ;;
   *)
-    AC_MSG_WARN([Octave has only been tested with g++, and I can't find it])
+    warn_gxx_only="Octave has only been tested with g++, and I can't find it"
+    AC_MSG_WARN($warn_gxx_only)
   ;;
 esac
 
@@ -247,10 +251,12 @@
     fi
   ;;
   1.*)
-    AC_MSG_WARN([gcc version $gcc_version is likely to cause problems])
+    warn_gcc_version="gcc version $gcc_version is likely to cause problems"
+    AC_MSG_WARN($warn_gcc_version)
   ;;
   *)
-    AC_MSG_WARN([Octave has only been tested with gcc, and I can't find it])
+    warn_gcc_only="Octave has only been tested with gcc, and I can't find it"
+    AC_MSG_WARN($warn_gcc_only)
   ;;
 esac
 
@@ -468,7 +474,8 @@
   fi
 
   if test -z "$FLIBS"; then
-    AC_MSG_WARN([I found f2c but not libf2c.a, or libF77.a and libI77.a])
+    warn_f2c_no_lib="I found f2c but not libf2c.a, or libF77.a and libI77.a"
+    AC_MSG_WARN($warn_f2c_no_lib)
   fi
   f77_rules_frag=Makefrag.f77
   cat << \EOF > $f77_rules_frag
@@ -921,7 +928,8 @@
     || test "$ac_cv_lib_termlib_tputs" = yes; then
   true
 else
-  AC_MSG_WARN([I couldn't find -ltermcap, -lterminfo, -lncurses, -lcurses, or -ltermlib!])
+  warn_termlibs="I couldn't find -ltermcap, -lterminfo, -lncurses, -lcurses, or -ltermlib!"
+  AC_MSG_WARN($warn_termlibs)
 fi
 
 AC_MSG_CHECKING([for struct exception in math.h])
@@ -1022,8 +1030,8 @@
   *)
     LFLAGS="-t"
     AC_MSG_RESULT([defining LFLAGS to be $LFLAGS])
-    AC_MSG_WARN([I didn't find flex, but that's only a problem])
-    AC_MSG_WARN([if you need to reconstruct lex.cc])
+    warn_flex="I didn't find flex, but it's only a problem if you need to reconstruct lex.cc"
+    AC_MSG_WARN($warn_flex)
   ;;
 esac
 AC_SUBST(LFLAGS)
@@ -1033,17 +1041,17 @@
   bison*)
   ;;
   *)
-    AC_MSG_WARN([I didn't find bison, but that's only a problem])
-    AC_MSG_WARN([if you need to reconstruct parse.cc])
+    warn_bison="I didn't find bison, but it's only a problem if you need to reconstruct parse.cc"
+    AC_MSG_WARN($warn_bison)
   ;;
 esac
 
 AC_PROG_LN_S
 
 AC_CHECK_PROG(RUNTEST, runtest, runtest, [])
-AC_CHECK_PROG(EXPECT, expect, expect, [])
-if test -z "$EXPECT"; then
-  RUNTEST=
+if test -z "$RUNTEST"; then
+  warn_runtest="I didn't find runtest -- install DejaGNU if you want to run \`make check'"
+  AC_MSG_WARN($warn_runtest)
 fi
 AC_SUBST(RUNTEST)
 
@@ -1077,6 +1085,11 @@
     AC_MSG_RESULT([no])
   fi
 else
+  warn_gnuplot="yes"
+
+  ## If you change this text, be sure to also copy it to the set of
+  ## warnings at the end of the script
+
   AC_MSG_WARN([I didn't find gnuplot.  It isn't necessary to have gnuplot])
   AC_MSG_WARN([installed, but you won't be able to use any of Octave's])
   AC_MSG_WARN([plotting commands without it.])
@@ -1098,7 +1111,8 @@
 
 AC_CHECK_PROGS(DEFAULT_PAGER, $octave_possible_pagers, [])
 if test -z "$DEFAULT_PAGER"; then
-  AC_MSG_WARN([I couldn't find `less', `more', `page', or `pg'])
+  warn_less="I couldn't find \`less', \`more', \`page', or \`pg'"
+  AC_MSG_WARN($warn_less)
 fi
 
 ### Even though we include config.h, we need to have the preprocessor
@@ -1218,3 +1232,89 @@
   Include support for GNU readline:        $USE_READLINE
   Include support for the GNU Info reader: $USE_GNU_INFO
 ])
+
+warn_msg_printed=false
+
+if test -n "$warn_f77_and_g77"; then
+  AC_MSG_WARN($warn_f77_and_g77)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_f2c_and_f77"; then
+  AC_MSG_WARN($warn_f2c_and_f77)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_f2c_and_g77"; then
+  AC_MSG_WARN($warn_f2c_and_g77)
+  warn_msg_printed=true
+fi
+
+if test -n "$gxx_only"; then
+  AC_MSG_WARN($gxx_only)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_gcc_version"; then
+  AC_MSG_WARN($warn_gcc_version)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_gcc_only"; then
+  AC_MSG_WARN($warn_gcc_only)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_f2c_no_lib"; then
+  AC_MSG_WARN($warn_f2c_no_lib)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_termlibs"; then
+  AC_MSG_WARN($warn_termlibs)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_flex"; then
+  AC_MSG_WARN($warn_flex)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_bison"; then
+  AC_MSG_WARN($warn_bison)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_less"; then
+  AC_MSG_WARN($warn_less)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_runtest"; then
+  AC_MSG_WARN($warn_runtest)
+  warn_msg_printed=true
+fi
+
+if test -n "$warn_gnuplot"; then
+
+  ## If you change this text, be sure to also change the corresponding
+  ## set of warnings above.
+
+  AC_MSG_WARN([I didn't find gnuplot.  It isn't necessary to have gnuplot])
+  AC_MSG_WARN([installed, but you won't be able to use any of Octave's])
+  AC_MSG_WARN([plotting commands without it.])
+  AC_MSG_WARN([])
+  AC_MSG_WARN([If gnuplot is installed but it isn't in your path, you can])
+  AC_MSG_WARN([tell Octave where to find it by typing the command])
+  AC_MSG_WARN([])
+  AC_MSG_WARN([gnuplot_binary = "/full/path/to/gnuplot/binary"])
+  AC_MSG_WARN([])
+  AC_MSG_WARN([at the Octave prompt.])
+  warn_msg_printed=true
+fi
+
+if $warn_msg_printed; then
+  AC_MSG_RESULT([])
+fi
+
+### End of configure.