diff libinterp/Makefile.am @ 16298:faaf60aa457c

use separate automake convenience library for bison and flex generated files * libinterp/Makefile.am (DIST_SRC): Include $(PARSER_SRC). (liboctinterp_la_LIBADD): Include parse-tree/libparser.la. * libinterp/parse-tree/module.mk (PARSE_TREE_INC): Remove $(PARSER_INC) from the list. (PARSE_TREE_SRC): Remove $(PARSER_SRC) from the list. (noinst_LTLIBRARIES): Include parse-tree/libparser.la in the list. (parse_tree_libparser_la_SOURCES, parse_tree_libparser_la_CPPFLAGS, parse_tree_libparser_la_CXXFLAGS): New varibles. Filter out -Wold-style-cast from CXXFLAGS for parser convenience library.
author John W. Eaton <jwe@octave.org>
date Wed, 13 Mar 2013 14:33:14 -0400
parents 05313332d541
children 7612d75a559b
line wrap: on
line diff
--- a/libinterp/Makefile.am	Wed Mar 13 11:22:31 2013 -0700
+++ b/libinterp/Makefile.am	Wed Mar 13 14:33:14 2013 -0400
@@ -125,6 +125,7 @@
   octave.cc \
   $(OCTAVE_VALUE_SRC) \
   $(PARSE_TREE_SRC) \
+  $(PARSER_SRC) \
   $(INTERP_CORE_SRC) \
   $(INTERPFCN_SRC) \
   $(COREFCN_SRC)
@@ -178,6 +179,7 @@
 liboctinterp_la_LIBADD = \
   octave-value/liboctave-value.la \
   parse-tree/libparse-tree.la \
+  parse-tree/libparser.la \
   interp-core/libinterp-core.la \
   interpfcn/libinterpfcn.la \
   corefcn/libcorefcn.la \