diff libinterp/Makefile.am @ 16050:fc3cb570ac46 classdef

periodic merge of default to classdef.
author Michael Goffioul <michael.goffioul@gmail.com>
date Mon, 11 Feb 2013 15:45:26 -0500
parents 0cbac4d3a81c 5b2126a8c84f
children 0259254a3ccc
line wrap: on
line diff
--- a/libinterp/Makefile.am	Mon Feb 11 15:24:56 2013 -0500
+++ b/libinterp/Makefile.am	Mon Feb 11 15:45:26 2013 -0500
@@ -230,6 +230,16 @@
 	  -DMAKE_BUILTINS $< | $(srcdir)/mkdefs $(srcdir) $< > $@-t
 	mv $@-t $@
 
+## Rules to build test files
+
+TST_FILES_SRC := $(shell $(top_srcdir)/build-aux/find-files-with-tests.sh "$(srcdir)" $(DIST_SRC) $(DLDFCN_SRC))
+
+TST_FILES := $(addsuffix -tst,$(TST_FILES_SRC))
+
+libinterptestsdir := $(octtestsdir)/libinterp
+
+nobase_libinterptests_DATA = $(TST_FILES)
+
 ## Override Automake's rule that forces a .hh extension on us even
 ## though we don't want it.  It would be super awesome if automake
 ## would allow users to choose the header file extension.