diff configure.in @ 3176:fccab8e7d35f

[project @ 1998-05-18 20:33:31 by jwe]
author jwe
date Mon, 18 May 1998 20:33:42 +0000
parents 390d5e396682
children d81db29f8b2b
line wrap: on
line diff
--- a/configure.in	Mon May 18 17:03:02 1998 +0000
+++ b/configure.in	Mon May 18 20:33:42 1998 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.304 $)
+AC_REVISION($Revision: 1.305 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -248,6 +248,13 @@
       XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee-with-inexact"
       AC_MSG_RESULT([adding -mieee-with-inexact to XTRA_CXXFLAGS])])
   ;;
+  *ibm-aix4*)
+    OCTAVE_CC_FLAG(-mno-fp-in-toc, [
+      XTRA_CFLAGS="$XTRA_CFLAGS -mno-fp-in-toc"])
+
+    OCTAVE_CXX_FLAG(-mno-fp-in-toc, [
+      XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mno-fp-in-toc"])
+  ;;
 esac
 
 ### Octave doesn't use run-time type identification or exceptions yet,
@@ -1121,6 +1128,8 @@
   libcruft/specfun/Makefile libcruft/slatec-fn/Makefile
   libcruft/slatec-err/Makefile libcruft/villad/Makefile)
 
+chmod 755 install-octave
+
 ### Print a summary so that important information isn't missed.
 
 if test -z "$F77"; then