diff configure.ac @ 30507:07ac55628691

maint: merge stable to default.
author Markus Mützel <markus.muetzel@gmx.de>
date Fri, 17 Dec 2021 21:33:01 +0100
parents 2be7ac9389cb e0e22183ffca
children 772e8f8e9054
line wrap: on
line diff
--- a/configure.ac	Fri Dec 17 19:41:48 2021 +0100
+++ b/configure.ac	Fri Dec 17 21:33:01 2021 +0100
@@ -2656,10 +2656,17 @@
      *) AC_MSG_ERROR([bad value $enableval for --enable-lib-visibility-flags]) ;;
    esac])
 
-if test $ENABLE_LIB_VISIBILITY_FLAGS = yes && test $HAVE_VISIBILITY = 0; then
-  AC_MSG_NOTICE([cannot build with visibility flags on this platform])
-  ENABLE_LIB_VISIBILITY_FLAGS=no
-fi
+case $host_os in
+  msdosmsvc | mingw* | cygwin*)
+    # Assume that symbol export is working on that platform
+  ;;
+  *)
+    if test $ENABLE_LIB_VISIBILITY_FLAGS = yes && test $HAVE_VISIBILITY = 0; then
+      AC_MSG_NOTICE([cannot build with visibility flags on this platform])
+      ENABLE_LIB_VISIBILITY_FLAGS=no
+    fi
+  ;;
+esac
 
 if test $ENABLE_LIB_VISIBILITY_FLAGS = yes; then
   AC_DEFINE(OCTAVE_ENABLE_LIB_VISIBILITY_FLAGS, 1,