diff Makefile.am @ 19841:07b970d6cdfe

Only install config.log in $octetc if user requested (bug #43087) * configure.ac: Add a --enable-install-build-logs configure option. Set AMCOND_INSTALL_BUILD_LOGS. * Makefile.am (octetc_DATA): Use AMCOND_INSTALL_BUILD_LOGS to include config.log in the list conditionally.
author Mike Miller <mtmiller@ieee.org>
date Mon, 23 Feb 2015 23:28:37 -0500
parents 7dbb8aa43d56
children d6879b59f46f
line wrap: on
line diff
--- a/Makefile.am	Mon Feb 23 23:05:30 2015 -0500
+++ b/Makefile.am	Mon Feb 23 23:28:37 2015 -0500
@@ -173,8 +173,11 @@
 
 octetc_DATA = \
   CITATION \
-  NEWS \
-  config.log
+  NEWS
+
+if AMCOND_INSTALL_BUILD_LOGS
+octetc_DATA += config.log
+endif
 
 doxyhtml:
 	$(MAKE) -C doc/doxyhtml doxyhtml