diff Makefile.am @ 32373:07e7a87dbeea

build: Add target "check-vm" to run test suite with enabled VM. * configure.ac: Define automake conditional AMCOND_ENABLE_VM_EVALUATOR when configured to build with VM evaluator. * Makefile.am (target check-vm): Conditionally, add new target that forwards to the Makefile in the "test" folder. * test/fntests.m: Use second command line argument for commands to be run before the actual test suite. * test/Makefile.am (function run-octave-tests): Add support for optional preparation commands. (target check-vm): Conditionally, add new target to run the test suite with enabled VM.
author Markus Mützel <markus.muetzel@gmx.de>
date Thu, 05 Oct 2023 18:43:07 +0200
parents 85723a361b2b
children 818698c4f296
line wrap: on
line diff
--- a/Makefile.am	Thu Oct 05 17:14:53 2023 -0400
+++ b/Makefile.am	Thu Oct 05 18:43:07 2023 +0200
@@ -349,6 +349,11 @@
 	$(AM_V_GEN)$(call simple-filter-rule,build-aux/subst-script-vals.sh) && \
 	chmod a+rx $@
 
+if AMCOND_ENABLE_VM_EVALUATOR
+check-vm:
+	$(MAKE) -C test check-vm
+endif
+
 octave-config.h: config.h build-aux/mk-octave-config-h.sh
 	$(AM_V_GEN)$(SHELL) $(srcdir)/build-aux/mk-octave-config-h.sh $< > $@-t && \
 	$(simple_move_if_change_rule)