diff configure.ac @ 32373:07e7a87dbeea

build: Add target "check-vm" to run test suite with enabled VM. * configure.ac: Define automake conditional AMCOND_ENABLE_VM_EVALUATOR when configured to build with VM evaluator. * Makefile.am (target check-vm): Conditionally, add new target that forwards to the Makefile in the "test" folder. * test/fntests.m: Use second command line argument for commands to be run before the actual test suite. * test/Makefile.am (function run-octave-tests): Add support for optional preparation commands. (target check-vm): Conditionally, add new target to run the test suite with enabled VM.
author Markus Mützel <markus.muetzel@gmx.de>
date Thu, 05 Oct 2023 18:43:07 +0200
parents aeed7db02016
children 7da49c0da993
line wrap: on
line diff
--- a/configure.ac	Thu Oct 05 17:14:53 2023 -0400
+++ b/configure.ac	Thu Oct 05 18:43:07 2023 +0200
@@ -1419,6 +1419,7 @@
   AC_DEFINE(OCTAVE_ENABLE_VM_EVALUATOR, 1,
     [Define to 1 to build experimental Virtual Machine evaluator.])
 fi
+AM_CONDITIONAL([AMCOND_ENABLE_VM_EVALUATOR], [test $ENABLE_VM_EVALUATOR = yes])
 
 ### Check for PCRE2 or PCRE regex library, requiring one to exist.