diff configure.ac @ 23646:0a5c6836c499

Use tgamma, tgammaf from C++ std library. These functions are guaranteed to be part of C++11 standard library. * configure.ac: Remove AC_CHECK_FUNCS for tgamma, tgammaf. Remove AC_CHECK_DECLS for tgamma. * lo-specfun.cc: Delegate to std::tgamma or std::tgammaf.
author Rik <rik@octave.org>
date Mon, 19 Jun 2017 10:30:55 -0700
parents e553b7b2fe39
children 864ac8dabeff
line wrap: on
line diff
--- a/configure.ac	Mon Jun 19 09:14:17 2017 -0700
+++ b/configure.ac	Mon Jun 19 10:30:55 2017 -0700
@@ -2411,7 +2411,7 @@
 AC_CHECK_FUNCS([lgamma lgammaf lgamma_r lgammaf_r])
 AC_CHECK_FUNCS([realpath resolvepath])
 AC_CHECK_FUNCS([select setgrent setpwent setsid siglongjmp strsignal])
-AC_CHECK_FUNCS([tcgetattr tcsetattr tgammaf toascii])
+AC_CHECK_FUNCS([tcgetattr tcsetattr toascii])
 AC_CHECK_FUNCS([umask waitpid])
 AC_CHECK_FUNCS([_getch _kbhit])
 
@@ -2419,23 +2419,6 @@
 AC_CHECK_FUNCS([sqrt sqrtf], [],
                [AC_MSG_ERROR([Missing function required to build Octave])])
 
-## exp2, round, tgamma function checks
-AC_LANG_PUSH(C++)
-AC_CHECK_DECLS([tgamma], [], [], [[#include <cmath>]])
-AC_CHECK_FUNCS([tgamma])
-AH_VERBATIM([Z_FUNCS_AND_DECLS], [
-#if defined (__cplusplus)
-extern "C" {
-#endif
-#if HAVE_TGAMMA && ! HAVE_DECL_TGAMMA
-double tgamma (double);
-#endif
-#if defined (__cplusplus)
-}
-#endif
-])
-AC_LANG_POP(C++)
-
 ## Look in <complex> for C++ variants of math functions that we need.
 
 OCTAVE_CHECK_FUNC_COMPLEX(acos)