diff configure.ac @ 33391:0d1a3c2ad9c6 stable

build: Correct result of std::pmr::polymorphic_allocator in configure summary. * configure.ac, m4/acinclude.m4 (OCTAVE_CHECK_STD_PMR_POLYMORPHIC_ALLOCATOR): The "--enable-std-pmr-polymorphic-allocator" configure flag means that polymorphic allocators should be used if possible. If that's not possible, indicate that they won't be used in the configure summary instead of echoing the value of the enable flag. See: https://octave.discourse.group/t/5481/73
author Markus Mützel <markus.muetzel@gmx.de>
date Sat, 13 Apr 2024 12:13:34 +0200
parents c59ff2782e04
children 35901ae8a563 75ef583dd829
line wrap: on
line diff
--- a/configure.ac	Sat Apr 06 14:43:10 2024 +0200
+++ b/configure.ac	Sat Apr 13 12:13:34 2024 +0200
@@ -370,6 +370,8 @@
 
 if test $ENABLE_STD_PMR_POLYMORPHIC_ALLOCATOR = yes; then
   OCTAVE_CHECK_STD_PMR_POLYMORPHIC_ALLOCATOR
+else
+  HAVE_STD_PMR_POLYMORPHIC_ALLOCATOR="no"
 fi
 
 ### Determine which C compiler to use (we expect to find gcc or clang).
@@ -3408,7 +3410,7 @@
   Use library visibility flags:         $ENABLE_LIB_VISIBILITY_FLAGS
   64-bit array dims and indexing:       $ENABLE_64
   64-bit BLAS array dims and indexing:  $HAVE_64_BIT_BLAS
-  Use std::pmr::polymorphic_allocator:  $ENABLE_STD_PMR_POLYMORPHIC_ALLOCATOR
+  Use std::pmr::polymorphic_allocator:  $HAVE_STD_PMR_POLYMORPHIC_ALLOCATOR
   OpenMP SMP multithreading:            $ENABLE_OPENMP
   Truncate intermediate FP results:     $ENABLE_FLOAT_TRUNCATE
   Include support for GNU readline:     $USE_READLINE