diff configure.ac @ 25843:144820478378 stable

eliminate OCTAVE_HAVE_FAST_INT_OPS macro and associated code (bug #54572) With current compilers, there no longer seems to be a performance advantage significant enough to justify the the trickery used in the special case code that was used when OCTAVE_HAVE_FAST_INT_OPS was defined. * acinclude.m4 (OCTAVE_FAST_INT_OPS): Delete macro. * configure.ac: Delete use. * mk-octave-config-h.sh: Don't recognize OCTAVE_HAVE_FAST_INT_OPS. * oct-inttypes.h, oct-inttypes.cc: (octave_int_arith_base<T,true>::abs, octave_int_arith_base<T,true>::minus, octave_int_arith_base<T,true>::add, octave_int_arith_base<T,true>::sub): Eliminate code blocks used if OCTAVE_HAVE_FAST_INT_OPS is defined.
author John W. Eaton <jwe@octave.org>
date Thu, 30 Aug 2018 10:03:09 -0400
parents 1f46d371968c
children dd10eea0be97 658153e1976d
line wrap: on
line diff
--- a/configure.ac	Wed Aug 29 14:33:36 2018 -0700
+++ b/configure.ac	Thu Aug 30 10:03:09 2018 -0400
@@ -1108,9 +1108,6 @@
 ## Are there functions to access real/imag parts of numbers via references?
 OCTAVE_CXX_COMPLEX_REFERENCE_ACCESSORS
 
-## Check if fast integer arithmetics based on bit tricks is available.
-OCTAVE_FAST_INT_OPS
-
 ## Does the C compiler handle alloca and const correctly?
 AC_FUNC_ALLOCA