diff configure.ac @ 30368:15ae4d97a632 stable

mkoctfile: Correctly handle relocation in cross-compiler. * configure.ac: Add new makefile variable AMCOND_RELOCATE_ALL. * src/module.mk (mkoctfile CROSS): Optionally, set OCTAVE_REPLACE_PREFIX. * src/mkoctfile.in.cc (replace_prefix): Simplify code. Style fix.
author Markus Mützel <markus.muetzel@gmx.de>
date Fri, 26 Nov 2021 22:08:49 +0100
parents 29efaa1d32d7
children 25ebd2cdf255 83dbee7c8f08
line wrap: on
line diff
--- a/configure.ac	Fri Nov 26 20:50:42 2021 +0100
+++ b/configure.ac	Fri Nov 26 22:08:49 2021 +0100
@@ -2627,6 +2627,7 @@
 if test $OCTAVE_RELOCATE_ALL = yes; then
   AC_DEFINE(OCTAVE_REPLACE_PREFIX, 1, [Replace prefix in mkoctfile flags.])
 fi
+AM_CONDITIONAL([AMCOND_RELOCATE_ALL], [test $OCTAVE_RELOCATE_ALL = yes])
 
 ### Determine whether Mercurial ID should be embedded in library binaries.