diff configure.in @ 2475:1d7925d6bede

[project @ 1996-11-07 04:36:00 by jwe]
author jwe
date Thu, 07 Nov 1996 04:46:54 +0000
parents 0c788e9b53b8
children ccaffe93c32f
line wrap: on
line diff
--- a/configure.in	Wed Nov 06 19:16:08 1996 +0000
+++ b/configure.in	Thu Nov 07 04:46:54 1996 +0000
@@ -20,7 +20,7 @@
 ### along with Octave; see the file COPYING.  If not, write to the Free
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-AC_REVISION($Revision: 1.227 $)
+AC_REVISION($Revision: 1.228 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -654,10 +654,10 @@
 AC_HEADER_SYS_WAIT
 
 AC_CHECK_HEADERS(assert.h curses.h fcntl.h float.h floatingpoint.h \
-		 limits.h memory.h pwd.h sgtty.h stdlib.h string.h \
-		 sys/param.h sys/resource.h sys/select.h sys/stat.h \
-		 sys/time.h sys/times.h sys/types.h sys/utsname.h \
-		 termcap.h termio.h termios.h unistd.h varargs.h) 
+  grp.h limits.h memory.h pwd.h sgtty.h stdlib.h string.h sys/param.h \
+  sys/resource.h sys/select.h sys/stat.h sys/time.h sys/times.h \
+  sys/types.h sys/utsname.h termcap.h termio.h termios.h unistd.h \
+  varargs.h)
 
 if test "$ac_cv_header_termios_h" = yes \
     || test "$ac_cv_header_termio_h" = yes \
@@ -695,14 +695,13 @@
 
 ### Checks for functions and variables.
 
-AC_CHECK_FUNCS(atexit bcopy bzero dup2 endpwent execvp fcntl fork \
-	       getcwd geteuid gethostname getpgrp getpid getppid \
-	       getpwent getpwnam getpwuid getuid lstat memmove mkdir \
-	       mkfifo on_exit pipe putenv rename rindex rmdir \
-	       setpwent setvbuf sigaction sigpending sigprocmask \
-	       sigsuspend stat strcasecmp strdup strerror stricmp \
-	       strncasecmp strnicmp tempnam umask unlink vfprintf \
-	       vsprintf waitpid)
+AC_CHECK_FUNCS(atexit bcopy bzero dup2 endgrent endpwent execvp fcntl \
+  fork getcwd getegid geteuid getgid getgrent getgrgid getgrnam \
+  gethostname getpgrp getpid getppid getpwent getpwnam getpwuid getuid \
+  lstat memmove mkdir mkfifo on_exit pipe putenv rename rindex rmdir \
+  setgrent setpwent setvbuf sigaction sigpending sigprocmask \
+  sigsuspend stat strcasecmp strdup strerror stricmp strncasecmp \
+  strnicmp tempnam umask unlink vfprintf vsprintf waitpid)
 
 OCTAVE_SMART_PUTENV
 OCTAVE_PROGRAM_INVOCATION_NAME
@@ -1069,18 +1068,18 @@
 ### Do the substitutions in all the Makefiles.
 
 AC_OUTPUT(Makefile octMakefile Makeconf test/Makefile dlfcn/Makefile
-	  doc/Makefile doc/faq/Makefile doc/interpreter/Makefile
-	  doc/liboctave/Makefile doc/refcard/Makefile examples/Makefile
-	  liboctave/Makefile src/Makefile src/mk-oct-links
-	  libcruft/Makefile libcruft/Makerules libcruft/blas/Makefile
-	  libcruft/balgen/Makefile libcruft/dassl/Makefile
-	  libcruft/eispack/Makefile libcruft/fftpack/Makefile
-	  libcruft/fsqp/Makefile libcruft/lapack/Makefile
-	  libcruft/linpack/Makefile libcruft/minpack/Makefile
-	  libcruft/misc/Makefile libcruft/npsol/Makefile
-	  libcruft/odepack/Makefile libcruft/qpsol/Makefile
-	  libcruft/quadpack/Makefile libcruft/ranlib/Makefile
-	  libcruft/slatec-fn/Makefile libcruft/villad/Makefile)
+  doc/Makefile doc/faq/Makefile doc/interpreter/Makefile
+  doc/liboctave/Makefile doc/refcard/Makefile examples/Makefile
+  liboctave/Makefile src/Makefile src/mk-oct-links libcruft/Makefile
+  libcruft/Makerules libcruft/blas/Makefile libcruft/balgen/Makefile
+  libcruft/dassl/Makefile libcruft/eispack/Makefile
+  libcruft/fftpack/Makefile libcruft/fsqp/Makefile
+  libcruft/lapack/Makefile libcruft/linpack/Makefile
+  libcruft/minpack/Makefile libcruft/misc/Makefile
+  libcruft/npsol/Makefile libcruft/odepack/Makefile
+  libcruft/qpsol/Makefile libcruft/quadpack/Makefile
+  libcruft/ranlib/Makefile libcruft/slatec-fn/Makefile
+  libcruft/villad/Makefile)
 
 ### Print a summary so that important information isn't missed.