diff Makefile.am @ 22042:21c12b837089

build: don't delete distributed docs on 'make clean' or 'make distclean' (bug #45646) * Makefile.am (clean-aminfo): Disable built-in Automake target that deletes Texinfo documentation on 'make clean'. * doc/module.mk (doc-maintainer-clean): Delete all built Texinfo documentation on 'make maintainer-clean'. * doc/interpreter/module.mk (doc_DISTCLEANFILES): Remove $(OCTAVE_HTML_STAMP) from the list.
author Mike Miller <mtmiller@octave.org>
date Tue, 05 Jul 2016 15:45:38 -0700
parents 659731a4563f
children d9643bc3792a
line wrap: on
line diff
--- a/Makefile.am	Tue Jul 05 12:15:04 2016 -0700
+++ b/Makefile.am	Tue Jul 05 15:45:38 2016 -0700
@@ -429,6 +429,12 @@
 
 maintainer-clean-local: doc-maintainer-clean
 
+## The 'clean-aminfo' target is defined by Automake >= 1.11.  We want to
+## distribute all Texinfo docs with the source distribution and not delete
+## them on 'clean', so we override this target to do nothing by default.
+
+clean-aminfo:
+
 define move_if_change_rule
   if [ -s $(1) ]; then \
     ${SHELL} ${top_srcdir}/build-aux/move-if-change $(1) $(2); \