diff Makefile.am @ 32530:23b20195a0a4 stable

restore option to disable bytecode evaluator removed in cset 6efda6ed0d17 * configure.ac: Restore --disable-bytecode-evaluator option and associated variables, renamed from --disable-vm-evaluator. * Makefile.am, test/Makefile.am (check-bytecode-evaluator): Rename target from check-vm. Now conditional on AMCOND_ENABLE_BYTECODE_EVALUATOR. * mk-octave-config-h.sh: Copy OCTAVE_ENABLE_BYTECODE_EVALUATOR macro. * toplev.cc (F__octave_config_info__): Include ENABLE_BYTECODE_EVALUATOR in the struct.
author John W. Eaton <jwe@octave.org>
date Tue, 28 Nov 2023 17:16:51 -0500
parents 6efda6ed0d17
children f561b6a31e02 b31991b5c361
line wrap: on
line diff
--- a/Makefile.am	Mon Dec 04 09:48:51 2023 +0100
+++ b/Makefile.am	Tue Nov 28 17:16:51 2023 -0500
@@ -349,8 +349,10 @@
 	$(AM_V_GEN)$(call simple-filter-rule,build-aux/subst-script-vals.sh) && \
 	chmod a+rx $@
 
-check-vm:
-	$(MAKE) -C test check-vm
+if AMCOND_ENABLE_BYTECODE_EVALUATOR
+check-bytecode-evaluator:
+	$(MAKE) -C test check-bytecode-evaluator
+endif
 
 octave-config.h: config.h build-aux/mk-octave-config-h.sh
 	$(AM_V_GEN)$(SHELL) $(srcdir)/build-aux/mk-octave-config-h.sh $< > $@-t && \