diff configure.ac @ 32335:2b44805fc139

build: Fail early when trying to build without shared libraries (bug #64709). * configure.ac: Fail early when configured with `--disable-shared`.
author Markus Mützel <markus.muetzel@gmx.de>
date Mon, 25 Sep 2023 18:52:36 +0200
parents 2c47affeec43
children 711ebddc86ea
line wrap: on
line diff
--- a/configure.ac	Mon Sep 25 16:35:09 2023 +0200
+++ b/configure.ac	Mon Sep 25 18:52:36 2023 +0200
@@ -613,6 +613,12 @@
   SHARED_LIBS=yes
 else
   SHARED_LIBS=no
+  # Note: Octave doesn't build currently without shared libraries.  And it
+  #       might not work or make sense at all to build static Octave libraries.
+  #       All existing logic for this use-case is still in place in case
+  #       someone would like to base on that to build static versions of the
+  #       libraries.
+  AC_MSG_ERROR([Building shared libraries is required!])
 fi
 AC_SUBST(SHARED_LIBS)