diff Makefile.am @ 20325:2d84d27dc9f0

eliminate recursive make invocation in src directory * src/module.mk: New file, created from src/Makefile.am. * src/Makefile.am: Delete. * configure.ac (AC_OUTPUT): Don't generate src/Makefile. * Makefile.am (SUBDIRS): Remove src. (ALL_LOCAL_TARGETS, bin_PROGRAMS, noinst_HEADERS, OCTAVE_VERSION_LINKS, OCTAVE_CROSS_TOOLS, archlib_PROGRAMS, OCTAVE_INTERPRETER_TARGETS): Initialize new variables. * doc/module.mk ($(GRAPH_PROP_TEXI_SRC), $(BUILT_IMAGES), doc/interpreter/doc-cache): Depend on $(OCTAVE_INTERPRETER_TARGETS). Fix dependencies for octave.html. Use $(abs_top_srcdir) instead of $(srcdir) in rules that use cd. * test/module.mk (GENERATED_TEST_FILES): New macro. (check-local, check-jit): Depend on $(OCTAVE_INTERPRETER_TARGETS) and $(GENERATED_TEST_FILES).
author John W. Eaton <jwe@octave.org>
date Thu, 09 Jul 2015 10:11:41 -0400
parents bacaec9b5535
children 8ef616eec739
line wrap: on
line diff
--- a/Makefile.am	Wed Jul 08 12:55:10 2015 -0400
+++ b/Makefile.am	Thu Jul 09 10:11:41 2015 -0400
@@ -66,6 +66,16 @@
 IMAGES_PNG =
 IMAGES_TXT =
 
+bin_PROGRAMS =
+archlib_PROGRAMS =
+noinst_HEADERS =
+OCTAVE_VERSION_LINKS =
+OCTAVE_CROSS_TOOLS =
+OCTAVE_INTERPRETER_TARGETS =
+
+ALL_LOCAL_TARGETS =
+
+include src/module.mk
 include doc/module.mk
 include doc/interpreter/images.mk
 include etc/module.mk
@@ -81,7 +91,7 @@
 if AMCOND_BUILD_GUI
 SUBDIRS += libgui
 endif
-SUBDIRS += src scripts
+SUBDIRS += scripts
 
 dist-hook: doc-interpreter-dist-hook docs-dist-hook icons-dist-hook
 
@@ -111,6 +121,8 @@
 
 noinst_SCRIPTS = run-octave
 
+OCTAVE_INTERPRETER_TARGETS += run-octave
+
 CLEANFILES += \
   $(BUILT_SOURCES)
 
@@ -127,7 +139,7 @@
 nodist_octinclude_HEADERS = config.h
 octinclude_HEADERS = oct-conf-post.h
 
-all-local: $(noinst_SCRIPTS) $(DIST_INFO_FILES) .gdbinit $(DOC_TARGETS)
+all-local: $(ALL_LOCAL_TARGETS) $(noinst_SCRIPTS) $(DIST_INFO_FILES) .gdbinit $(DOC_TARGETS)
 	@echo ""
 	@echo "Octave successfully built.  Now choose from the following:"
 	@echo ""