diff configure.ac @ 22759:39f39eb4e476

Implement "linejoin" property (bug #48387) * configure.ac: test whether gl2psLineJoin function is available in gl2ps * graphics.in.h (line::properties): add "linejoin" property * gl-render.h (opengl_renderer::set_linejoin): new virtual method, does nothing by default. * gl-render.cc (opengl_renderer::draw_line): make use of "linejoin" property * gl-render.cc (opengl_renderer::draw_patch/suface): force "miter" line join * gl2ps-print.cc (gl2ps_renderer::set_linejoin): call gl2psLineJoin conditioned on HAVE_GL2PSLINEJOIN. * genpropdoc.m: document linejoin property.
author Pantxo Diribarne <pantxo.diribarne@gmail.com>
date Thu, 27 Oct 2016 09:24:58 +0200
parents 3a2b891d0b33
children 57e82b74f89b
line wrap: on
line diff
--- a/configure.ac	Sun Nov 13 21:27:41 2016 -0800
+++ b/configure.ac	Thu Oct 27 09:24:58 2016 +0200
@@ -1746,6 +1746,11 @@
 
 if test -n "$warn_gl2ps"; then
   OCTAVE_CONFIGURE_WARNING([warn_gl2ps])
+else
+  save_LIBS="$LIBS"
+  LIBS="$GL2PS_LIBS $LIBS"
+  AC_CHECK_FUNCS([gl2psLineJoin])
+  LIBS="$save_LIBS"
 fi
 
 AC_SUBST(GL2PS_LIBS)