diff Makefile.am @ 16178:3a93af21d206

New function citation() to display citation information (patch #7960) * display_info_file.m: the new function is pretty much the same as news() so this new private function is their common code * citation.m: the new function * help.m: changed to use the private function with common code with citation() * CITATION: new file with citation instructions for Octave core * Makefile.am: add CITATION file into the build system and install into octetc * bootstrap.conf: make sure that the CITATION is present when installing * copy_files.m: make pkg() check and install CITATION files from packages * doc/interpreter/package.txi: document optional CITATION files for packages
author Carnë Draug <carandraug@octave.org>
date Sun, 03 Mar 2013 02:34:44 +0000
parents 6076458ddf98
children 7d0848353eaf
line wrap: on
line diff
--- a/Makefile.am	Sat Mar 02 19:31:26 2013 -0500
+++ b/Makefile.am	Sun Mar 03 02:34:44 2013 +0000
@@ -37,6 +37,7 @@
   INSTALL.OCTAVE \
   NEWS \
   README \
+  CITATION \
   bootstrap \
   bootstrap.conf \
   build-aux/find-files-with-tests.sh \
@@ -132,7 +133,9 @@
 	mv $@.t $@
 .PHONY: ChangeLog
 
-octetc_DATA = NEWS
+octetc_DATA = \
+  NEWS \
+  CITATION
 
 DIRS_TO_MAKE = \
   $(localfcnfiledir) \