diff configure.ac @ 10341:43145faf9af8

Move $(pcre_config --cflags) from CPPFLAGS to XTRA_CXXFLAGS
author Michael Goffioul <michael.goffioul@gmail.com>
date Sun, 21 Feb 2010 17:27:57 +0000
parents 5f6298220ced
children 65d5776379c3
line wrap: on
line diff
--- a/configure.ac	Fri Feb 19 16:31:31 2010 -0500
+++ b/configure.ac	Sun Feb 21 17:27:57 2010 +0000
@@ -615,10 +615,10 @@
 
 ### Check for pcre/regex library.
 
-## check for pcre-config, and if so, set CPPFLAGS appropriately
+## check for pcre-config, and if so, set XTRA_CXXFLAGS appropriately
 AC_CHECK_PROG(WITH_PCRE_CONFIG, pcre-config, yes, no)
 if test $WITH_PCRE_CONFIG = yes ; then
-  CPPFLAGS="$CPPFLAGS $(pcre-config --cflags)"
+  XTRA_CXXFLAGS="$XTRA_CXXFLAGS $(pcre-config --cflags)"
 fi
 
 ## NB: no need to do separate check for pcre.h header -- checking macros is good enough