diff libinterp/Makefile.am @ 21679:44f7664689f2 stable

make __magick_read__ a built-in function (bug #41699) * libinterp/Makefile.am (AM_CPPFLAGS): Add $(MAGICK_CPPFLAGS) to the list. * corefcn/__magick_read__.cc: Rename from dldfcn/__magick_read__.cc. Change DEFUN_DLD to DEFUN. * libinterp/dldfcn/module-files: Delete entry for __magick_read__.cc. * libinterp/corefcn/module.mk: Update. * libinterp/link-deps.mk (LIBOCTINTERP_LINK_DEPS): Add $MAGICK_LIBS to the list. (LIBOCTINTERP_LINK_OPTS): Add $MAGICK_LDFLAGS to the list.
author John W. Eaton <jwe@octave.org>
date Fri, 06 May 2016 17:02:31 -0400
parents acaf1e137c5e
children
line wrap: on
line diff
--- a/libinterp/Makefile.am	Wed May 04 14:11:47 2016 -0700
+++ b/libinterp/Makefile.am	Fri May 06 17:02:31 2016 -0400
@@ -33,7 +33,8 @@
   -Iparse-tree -I$(srcdir)/parse-tree \
   -Icorefcn -I$(srcdir)/corefcn \
   -I$(top_builddir)/libgnu -I$(top_srcdir)/libgnu \
-  $(HDF5_CPPFLAGS)
+  $(HDF5_CPPFLAGS) \
+  $(MAGICK_CPPFLAGS)
 
 AM_CFLAGS += $(WARN_CFLAGS)