diff Makefile.am @ 20306:47d704435aa4

eliminate recursive make invocation in etc/icons directory * etc/module.mk: New file. * etc/icons/Makefile.am: Move contents to etc/module.mk and Makefile.am. Adapt filenames as needed. * Makefile.am (EXTRA_DIST): Move list of files in etc directory to etc/module.mk. (SUBDIRS): Remove etc/icons from the list. * configure.ac (AC_OUTPUT): Don't generate etc/icons/Makefile.
author John W. Eaton <jwe@octave.org>
date Fri, 03 Jul 2015 07:51:51 -0400
parents d6879b59f46f
children c3c1fb44f9b5
line wrap: on
line diff
--- a/Makefile.am	Thu Jul 02 18:07:24 2015 -0400
+++ b/Makefile.am	Fri Jul 03 07:51:51 2015 -0400
@@ -46,28 +46,13 @@
   build-aux/move-if-change \
   build-aux/OctJavaQry.class \
   build-aux/stl_algo.h-fixed \
-  etc/NEWS.1 \
-  etc/NEWS.2 \
-  etc/NEWS.3 \
-  etc/OLD-ChangeLogs/ChangeLog \
-  etc/OLD-ChangeLogs/ChangeLog.1 \
-  etc/OLD-ChangeLogs/doc-ChangeLog \
-  etc/OLD-ChangeLogs/libcruft-ChangeLog \
-  etc/OLD-ChangeLogs/liboctave-ChangeLog \
-  etc/OLD-ChangeLogs/scripts-ChangeLog \
-  etc/OLD-ChangeLogs/src-ChangeLog \
-  etc/OLD-ChangeLogs/test-ChangeLog \
-  etc/PROJECTS \
-  etc/README.Cygwin \
-  etc/README.Linux \
-  etc/README.MacOS \
-  etc/README.MinGW \
-  etc/README.Windows \
-  etc/README.gnuplot \
-  etc/README.kpathsea \
-  etc/gdbinit \
   run-octave.in
 
+CLEANFILES =
+DISTCLEANFILES =
+MAINTAINERCLEANFILES =
+
+include etc/module.mk
 include examples/module.mk
 include m4/module.mk
 
@@ -85,11 +70,22 @@
 if AMCOND_BUILD_GUI
 SUBDIRS += libgui
 endif
-SUBDIRS += src scripts . @DOCDIR@ etc/icons test .
+SUBDIRS += src scripts . @DOCDIR@ test .
+
+dist-hook: docs-dist-hook icons-dist-hook
 
-if ! AMCOND_BUILD_DOCS
-dist-hook:
-	echo "Documentation disabled.  Cannot package distribution!" ; exit 1;
+if AMCOND_BUILD_DOCS
+docs-dist-hook:
+else
+docs-dist-hook:
+	@echo "Documentation disabled.  Cannot package distribution!" ; exit 1;
+endif
+
+if AMCOND_HAVE_ICON_TOOLS
+icons-dist-hook:
+else
+icons-dist-hook:
+	@echo "Packaging distribution requires icotool and rsvg-convert." ; exit 1;
 endif
 
 BUILT_SOURCES = run-octave
@@ -107,13 +103,15 @@
   BUGS \
   INSTALL.OCTAVE
 
-CLEANFILES = $(BUILT_SOURCES)
+CLEANFILES += \
+  $(BUILT_SOURCES)
 
-DISTCLEANFILES = \
+DISTCLEANFILES += \
   .gdbinit \
   ChangeLog
 
-MAINTAINERCLEANFILES = $(BUILT_DISTFILES)
+MAINTAINERCLEANFILES += \
+  $(BUILT_DISTFILES)
 
 CONFIG_FILES = @ac_config_headers@ @ac_config_files@