diff configure.ac @ 33163:4cbbc280c69d

build: Revert to building with polymorphic allocator by default. * configure.ac: Revert default to --enable-std-pmr-polymorphic-allocator that was accidentally changed in 4584cb4207f1.
author Markus Mützel <markus.muetzel@gmx.de>
date Thu, 07 Mar 2024 08:24:51 +0100
parents 4584cb4207f1
children 88a08496297a a79e07f980ff
line wrap: on
line diff
--- a/configure.ac	Wed Mar 06 22:54:49 2024 -0500
+++ b/configure.ac	Thu Mar 07 08:24:51 2024 +0100
@@ -317,7 +317,7 @@
 ## Preferably with GNU extensions if flags are required.
 AX_CXX_COMPILE_STDCXX(17, [], mandatory)
 
-ENABLE_STD_PMR_POLYMORPHIC_ALLOCATOR=no
+ENABLE_STD_PMR_POLYMORPHIC_ALLOCATOR=yes
 AC_ARG_ENABLE(std-pmr-polymorphic-allocator,
   [AS_HELP_STRING([--disable-std-pmr-polymorphic-allocator],
     [build libraries that do not require support for std::pmr::polymorphic_allocator.  This prevents more efficient transfer of arrays at the .mex file interface.])],