diff configure.ac @ 31129:4dc326899f65

build: simplify BLAS library detection in configure (bug #62715) * configure.ac: Replace calls to OCTAVE_BLAS_F77_FUNC with OCTAVE_BLAS. * m4/octave_blas_f77_func.m4: Removed obsolete macro file. * m4/octave_blas.m4: New file with OCTAVE_BLAS macro to detect BLAS library and find size of integers in library. * m4/module.mk: Add octave_blas.m4 to build system.
author Rik <rik@octave.org>
date Fri, 08 Jul 2022 21:38:05 -0700
parents c4f52c6c5944
children 60f32b7455e3
line wrap: on
line diff
--- a/configure.ac	Fri Jul 08 12:57:54 2022 +0200
+++ b/configure.ac	Fri Jul 08 21:38:05 2022 -0700
@@ -710,10 +710,7 @@
 save_FFLAGS="$FFLAGS"
 FFLAGS="$FFLAGS $F77_INTEGER_8_FLAG"
 
-OCTAVE_BLAS_WITH_F77_FUNC([], [],
-  [ax_blas_ok=yes
-  AC_MSG_CHECKING([BLAS can be called from Fortran])
-  AC_MSG_RESULT([yes assumed for cross compilation])])
+OCTAVE_BLAS
 AX_LAPACK
 
 ## Restore FFLAGS.
@@ -724,7 +721,7 @@
   save_FFLAGS="$FFLAGS"
   FFLAGS="-ff2c $FFLAGS $F77_INTEGER_8_FLAG"
 
-  OCTAVE_BLAS_WITH_F77_FUNC
+  OCTAVE_BLAS
   AX_LAPACK
 
   ## Restore FFLAGS, with -ff2c if that was helpful
@@ -753,7 +750,7 @@
          save_FFLAGS="$FFLAGS"
          FFLAGS="$FFLAGS $F77_INTEGER_8_FLAG"
 
-         OCTAVE_BLAS_WITH_F77_FUNC
+         OCTAVE_BLAS
          AX_LAPACK
 
          ## Restore FFLAGS.