diff Makefile.am @ 19792:4f6ae6b94abe

make --enable-silent-rules configure option more useful * sparse-mx-ops: Rename from smx-ops. * genpropdoc.m: Write to stdout if filename is not supplied. * Makefile.am, build-aux/common.mk, doc/interpreter/Makefile.am, doc/interpreter/graphics_properties.mk, etc/icons/Makefile.am, libgui/Makefile.am, libinterp/Makefile.am, libinterp/corefcn/module.mk, libinterp/octave-value/module.mk, libinterp/operators/module.mk, libinterp/parse-tree/module.mk, liboctave/cruft/module.mk, liboctave/cruft/ranlib/module.mk, liboctave/cruft/slatec-fn/module.mk, liboctave/numeric/module.mk, liboctave/operators/module.mk, scripts/Makefile.am, scripts/java/module.mk, src/Makefile.am, test/Makefile.am: Preface rules with $(AM_V_GEN) or similar as needed. Improve consistency of rules. Prefer commands that write to stdout, redirecting output to $@-t, then moving to $@. * doc/interpreter/images.awk, libinterp/dldfcn/config-module.awk: Generate rules with $(AM_V_GEN).
author John W. Eaton <jwe@octave.org>
date Fri, 20 Feb 2015 17:18:19 -0500
parents 4197fc428c7d
children 0093b9987ee0
line wrap: on
line diff
--- a/Makefile.am	Fri Feb 20 08:45:23 2015 -0800
+++ b/Makefile.am	Fri Feb 20 17:18:19 2015 -0500
@@ -135,11 +135,11 @@
 endif
 
 run-octave: run-octave.in Makefile
-	@$(do_subst_script_vals)
+	$(AM_V_GEN)$(do_subst_script_vals) && \
 	chmod a+rx "$@"
 
 bits/stl_algo.h: build-aux/stl_algo.h-fixed
-	$(MKDIR_P) bits
+	$(AM_V_GEN)$(MKDIR_P) bits && \
 	$(INSTALL_HEADER) $< $@
 
 ## If we aren't trying to fix stl_algo.h, then try to ensure that
@@ -154,13 +154,22 @@
 
 if AMCOND_BUILD_DOCS
 AUTHORS BUGS INSTALL.OCTAVE:
-	$(MAKE) -C doc/interpreter ../../$@
+	$(AM_V_GEN)$(MAKE) -C doc/interpreter ../../$@
 endif
 .PHONY: AUTHORS BUGS INSTALL.OCTAVE
 
+define changelog-from-hg-log
+  rm -f $@-t $@ && \
+  { cd $(srcdir); \
+    hg log --style=build-aux/changelog.tmpl --prune=b0e60ad4ae26 --only-branch=`hg branch`; \
+    echo ""; \
+    echo "See the files in the directory etc/OLD-ChangeLogs for changes before 2011-04-19" \
+  } > $@-t && \
+  mv $@-t $@
+endef
+
 ChangeLog:
-	(cd $(srcdir); hg log --style=build-aux/changelog.tmpl --prune=b0e60ad4ae26 --only-branch=`hg branch`; echo ""; echo "See the files in the directory etc/OLD-ChangeLogs for changes before 2011-04-19") > $@.t
-	mv $@.t $@
+	$(AM_V_GEN)$(changelog-from-hg-log)
 .PHONY: ChangeLog
 
 octetc_DATA = \