diff src/Makefile.am @ 12163:55ebf5df9ea6

Use Automake and GNU Make variables for increased portability in DLD-FUNCTIONS/*.oct creation
author Rik <octave@nomad.inbox5.com>
date Tue, 25 Jan 2011 21:38:05 -0800
parents c9f42acd84e2
children c7370ea55ee8
line wrap: on
line diff
--- a/src/Makefile.am	Tue Jan 25 19:54:06 2011 -0800
+++ b/src/Makefile.am	Tue Jan 25 21:38:05 2011 -0800
@@ -467,7 +467,7 @@
   DLD_DYNAMIC_SRC = $(DLD_FUNCTIONS_SRC)
   DLD_STATIC_SRC =
   OCT_FILES = $(DLD_FUNCTIONS_LIBS:.la=.oct)
-  OCT_STAMP_FILES = $(subst DLD-FUNCTIONS/,DLD-FUNCTIONS/., $(DLD_FUNCTIONS_LIBS:.la=.oct-stamp))
+  OCT_STAMP_FILES = $(subst DLD-FUNCTIONS/,DLD-FUNCTIONS/$(am__leading_dot),$(DLD_FUNCTIONS_LIBS:.la=.oct-stamp))
 else
   DLD_DYNAMIC_SRC =
   DLD_STATIC_SRC = $(DLD_FUNCTIONS_SRC)
@@ -720,8 +720,8 @@
 	done
 
 uninstall-oct:
-	for f in $(OCT_FILES); do \
-	  rm -f $(DESTDIR)$(octfiledir)/`echo $$f | $(SED) 's,.*/,,'`; \
+	for f in $(notdir $(OCT_FILES)); do \
+	  rm -f $(DESTDIR)$(octfiledir)/$$f; \
 	done
 	rm -f $(DESTDIR)$(octfiledir)/PKG_ADD
 endif