diff src/Makefile.am @ 15088:60ff2cef569d

maint: Move core interpreter files with DEFUNS to interpfcn/ directory * src/Makefile.am: Adjust build system for new location of files. * interpfcn/module.mk: Add files and rules to build system. * data.cc, data.h, debug.cc, debug.h, defaults.cc, defaults.in.h, defun.cc, defun.h, dirfns.cc, dirfns.h, error.cc, error.h, file-io.cc, file-io.h, graphics.cc, graphics.in.h, help.cc, help.h, input.cc, input.h, load-path.cc, load-path.h, load-save.cc, load-save.h, ls-oct-ascii.cc, ls-oct-ascii.h, oct-hist.cc, oct-hist.h, pager.cc, pager.h, pr-output.cc, pr-output.h, profiler.cc, profiler.h, sighandlers.cc, sighandlers.h, symtab.cc, symtab.h, sysdep.cc, sysdep.h, toplev.cc, toplev.h, utils.cc, utils.h, variables.cc, variables.h: Move files to interpfcn/ directory
author Rik <rik@octave.org>
date Fri, 03 Aug 2012 09:31:37 -0700
parents a782752adcf3
children 959953dba519 909a2797935b
line wrap: on
line diff
--- a/src/Makefile.am	Fri Aug 03 11:37:02 2012 -0400
+++ b/src/Makefile.am	Fri Aug 03 09:31:37 2012 -0700
@@ -22,13 +22,14 @@
 
 ## Search local directories before those specified by the user.
 AM_CPPFLAGS = \
-  -I../libgnu -I$(top_srcdir)/libgnu \
   -I$(top_srcdir)/libcruft/misc \
   -I../liboctave -I$(top_srcdir)/liboctave \
+  -Iinterpfcn -I$(srcdir)/interpfcn \
   -Icorefcn \
   -Ioctave-value -I$(srcdir)/octave-value \
   -Iparse-tree -I$(srcdir)/parse-tree \
   -I. -I$(srcdir) \
+  -I../libgnu -I$(top_srcdir)/libgnu \
   @CPPFLAGS@
 
 AUTOMAKE_OPTIONS = subdir-objects
@@ -66,9 +67,9 @@
 ## (except builtins.cc) to be available.
 BUILT_SOURCES = \
   $(BUILT_SOURCES_EXTRA) \
-  defaults.h \
-  graphics.h \
-  graphics-props.cc \
+  interpfcn/defaults.h \
+  interpfcn/graphics.h \
+  interpfcn/graphics-props.cc \
   parse-tree/lex.cc \
   mxarray.h \
   oct-conf.h \
@@ -81,13 +82,13 @@
 
 BUILT_DISTFILES = \
   oct-gperf.h \
-  oct-parse.h
+  parse-tree/oct-parse.h
 
 ## Files that are created during build process and installed,
 ## BUT not distributed in tarball.
 BUILT_NODISTFILES = \
-  defaults.h \
-  graphics.h \
+  interpfcn/defaults.h \
+  interpfcn/graphics.h \
   oct-conf.h \
   oct-errno.cc \
   ops.cc \
@@ -135,31 +136,20 @@
   c-file-ptr-stream.h \
   comment-list.h \
   cutils.h \
-  data.h \
-  debug.h \
   defun-dld.h \
   defun-int.h \
-  defun.h \
-  dirfns.h \
   display.h \
   dynamic-ld.h \
-  error.h \
-  file-io.h \
   gl-render.h \
   gl2ps.h \
   gl2ps-renderer.h \
-  graphics-props.cc \
+  interpfcn/graphics-props.cc \
   gripes.h \
-  help.h \
-  input.h \
-  load-path.h \
-  load-save.h \
   ls-ascii-helper.h \
   ls-hdf5.h \
   ls-mat-ascii.h \
   ls-mat4.h \
   ls-mat5.h \
-  ls-oct-ascii.h \
   ls-oct-binary.h \
   ls-utils.h \
   mex.h \
@@ -168,7 +158,6 @@
   oct-fstrm.h \
   oct-gperf.h \
   oct-hdf5.h \
-  oct-hist.h \
   oct-iostrm.h \
   oct-lvalue.h \
   oct-map.h \
@@ -181,23 +170,14 @@
   oct.h \
   octave.h \
   ops.h \
-  pager.h \
-  pr-output.h \
   procstream.h \
-  profiler.h \
-  sighandlers.h \
   siglist.h \
   sparse-xdiv.h \
   sparse-xpow.h \
-  symtab.h \
-  sysdep.h \
   token.h \
-  toplev.h \
   txt-eng-ft.h \
   txt-eng.h \
   unwind-prot.h \
-  utils.h \
-  variables.h \
   xdiv.h \
   xnorm.h \
   xpow.h \
@@ -205,11 +185,12 @@
   $(OV_INCLUDES) \
   $(OV_SPARSE_INCLUDES) \
   $(PT_INCLUDES) \
+  $(INTERPFCN_INCLUDES) \
   $(JIT_INCLUDES)
 
 nodist_octinclude_HEADERS = \
-  defaults.h \
-  graphics.h \
+  interpfcn/defaults.h \
+  interpfcn/graphics.h \
   oct-conf.h \
   mxarray.h \
   version.h
@@ -225,35 +206,21 @@
   c-file-ptr-stream.cc \
   comment-list.cc \
   cutils.c \
-  data.cc \
-  debug.cc \
-  defaults.cc \
-  defun.cc \
-  dirfns.cc \
   display.cc \
   dynamic-ld.cc \
-  error.cc \
-  file-io.cc \
   gl-render.cc \
   gl2ps-renderer.cc \
-  graphics.cc \
   gripes.cc \
-  help.cc \
-  input.cc \
-  load-path.cc \
-  load-save.cc \
   ls-ascii-helper.cc \
   ls-hdf5.cc \
   ls-mat-ascii.cc \
   ls-mat4.cc \
   ls-mat5.cc \
-  ls-oct-ascii.cc \
   ls-oct-binary.cc \
   ls-utils.cc \
   matherr.c \
   mex.cc \
   oct-fstrm.cc \
-  oct-hist.cc \
   oct-iostrm.cc \
   oct-lvalue.cc \
   oct-map.cc \
@@ -263,31 +230,23 @@
   oct-stream.cc \
   oct-strstrm.cc \
   octave.cc \
-  pager.cc \
-  pr-output.cc \
   procstream.cc \
-  profiler.cc \
-  sighandlers.cc \
   siglist.c \
   sparse-xdiv.cc \
   sparse-xpow.cc \
-  symtab.cc \
-  sysdep.cc \
   token.cc \
-  toplev.cc \
   txt-eng-ft.cc \
   unwind-prot.cc \
-  utils.cc \
-  variables.cc \
   xdiv.cc \
   xgl2ps.c \
   xnorm.cc \
   xpow.cc \
   zfstream.cc \
-  $(COREFCN_SRC) \
   $(OCTAVE_VALUE_SRC) \
   $(PARSE_TREE_SRC) \
-  $(JIT_SRC)
+  $(JIT_SRC) \
+  $(INTERPFCN_SRC) \
+  $(COREFCN_SRC)
 
 noinst_LTLIBRARIES =
 
@@ -295,6 +254,7 @@
 include octave-value/module.mk
 include operators/module.mk
 include template-inst/module.mk
+include interpfcn/module.mk
 include corefcn/module.mk
 include dldfcn/module.mk
 
@@ -318,8 +278,8 @@
 
 nodist_liboctinterp_la_SOURCES = \
   builtins.cc \
-  defaults.h \
-  graphics.h \
+  interpfcn/defaults.h \
+  interpfcn/graphics.h \
   mxarray.h \
   oct-conf.h \
   oct-errno.cc \
@@ -401,13 +361,6 @@
 ## defaults.h and oct-conf.h must depend on Makefile.  Calling configure
 ## may change default/config values.  However, calling configure will also
 ## regenerate the Makefiles from Makefile.am and trigger the rules below.
-defaults.h: defaults.in.h Makefile
-	@$(do_subst_default_vals)
-
-graphics.h: graphics.in.h genprops.awk Makefile
-	$(AWK) -f $(srcdir)/genprops.awk $< > $@-t
-	mv $@-t $@
-
 oct-conf.h: oct-conf.in.h Makefile
 	@$(do_subst_config_vals)
 
@@ -439,10 +392,6 @@
 	$(srcdir)/mkbuiltins $(DEF_FILES) > $@-t
 	mv $@-t $@
 
-graphics-props.cc: graphics.in.h genprops.awk Makefile
-	$(AWK) -v emit_graphics_props=1 -f $(srcdir)/genprops.awk $< > $@-t
-	mv $@-t $@
-
 ops.cc: $(OPERATORS_SRC) mkops
 	$(srcdir)/mkops $(OPERATORS_SRC) > $@-t
 	mv $@-t $@
@@ -568,8 +517,8 @@
 CLEANFILES = \
   $(bin_SCRIPTS) \
   $(DLDFCN_PKG_ADD_FILE) \
-  graphics-props.cc \
-  oct-parse.output
+  interpfcn/graphics-props.cc \
+  parse-tree/oct-parse.output
 
 DISTCLEANFILES = \
   .DOCSTRINGS \