diff Makefile.am @ 22024:659731a4563f

build: delete generated files, keep distributed files on clean and distclean (bug #45646) * Makefile.am (CLEANFILES): Add octave-config.h and run-octave to the list. Remove $(BUILT_SOURCES) from the list. (DISTCLEANFILES): Add $(GEN_CONFIG_INC) to the list. (nodist_octinclude_HEADERS): Add oct-conf-post.h to the list. * libgui/src/module.mk (libgui_CLEANFILES): Add libgui/src/liboctgui-build-info.cc to the list. (libgui_DISTCLEANFILES): Remove libgui/src/liboctgui-build-info.cc from the list. * libinterp/module.mk (LIBINTERP_BUILT_NODISTFILES): Add libinterp/corefcn/graphics-props.cc to the list. (nodist_octinclude_HEADERS): Add libinterp/builtin-defun-decls.h and libinterp/corefcn/graphics-props.cc to the list. (octinclude_HEADERS): Remove libinterp/builtin-defun-decls.h and libinterp/corefcn/graphics-props.cc from the list. (libinterp_CLEANFILES): Add $(LIBINTERP_BUILT_NODISTFILES) to the list, replacing libinterp/corefcn/graphics-props.cc. (libinterp_DISTCLEANFILES): Remove $(LIBINTERP_BUILT_NODISTFILES) from the list. * liboctave/cruft/module.mk (liboctave_CLEANFILES): Add the previous contents of $(liboctave_DISTCLEANFILES) to the list. * liboctave/module.mk (liboctave_CLEANFILES): Add $(LIBOCTAVE_BUILT_NODISTFILES) to the list. (liboctave_DISTCLEANFILES): Remove $(LIBOCTAVE_BUILT_NODISTFILES) and $(BUILT_INCS) from the list. * liboctave/numeric/module.mk (liboctave_CLEANFILES): Add $(LIBOCTAVE_OPT_INC) to the list. * liboctave/operators/module.mk (liboctave_CLEANFILES): Add $(BUILT_LIBOCTAVE_OPERATORS_FILES) to the list. (liboctave_DISTCLEANFILES): Remove $(BUILT_LIBOCTAVE_OPERATORS_SOURCES) from the list. * scripts/module.mk (scripts_CLEANFILES): Add $(GEN_FCN_FILES) to the list. (scripts_DISTCLEANFILES): Remove $(GEN_FCN_FILES) from the list. * src/module.mk (src_CLEANFILES): Add src/main.cc, src/mkoctfile.cc, src/octave-build-info.cc, and src/octave-config.cc to the list. (src_DISTCLEANFILES): Remove src/octave-config-build-info.cc from the list. (DISTCLEANFILES): Remove src/main.cc, src/mkoctfile.cc, and src/octave-config.cc from the list.
author Mike Miller <mtmiller@octave.org>
date Fri, 01 Jul 2016 10:51:49 -0700
parents e154d23b2fd1
children 21c12b837089
line wrap: on
line diff
--- a/Makefile.am	Fri Jul 01 20:12:57 2016 -0700
+++ b/Makefile.am	Fri Jul 01 10:51:49 2016 -0700
@@ -289,12 +289,14 @@
 noinst_SCRIPTS = run-octave
 
 CLEANFILES += \
-  $(BUILT_SOURCES) \
   config-vars \
-  make-vars
+  make-vars \
+  octave-config.h \
+  run-octave
 
 DISTCLEANFILES += \
   $(DIRSTAMP_FILES) \
+  $(GEN_CONFIG_INC) \
   $(GEN_CONFIG_SHELL) \
   .gdbinit
 
@@ -305,8 +307,10 @@
 
 CONFIG_FILES = @ac_config_headers@ @ac_config_files@
 
-octinclude_HEADERS += oct-conf-post.h
-nodist_octinclude_HEADERS += config.h octave-config.h
+nodist_octinclude_HEADERS += \
+  config.h \
+  oct-conf-post.h \
+  octave-config.h
 
 ALL_LOCAL_TARGETS += \
   $(OCTAVE_INTERPRETER_TARGETS) \