diff configure.ac @ 29354:6c2fa2293242

Increase Windows API version to Windows 7 (bug #60014). * configure.ac: Increase minimum value of _WIN32_WINNT to 0x0601 (Windows 7). * libinterp/corefcn/sysdep.cc (set_application_id): Call "SetCurrentProcessExplicitAppUserModelID" directly. * liboctave/system/oct-time.cc (base_tm::init): Call "GetTimeZoneInformationForYear" unconditionally. * NEWS: Add note about new minimum Windows version.
author Markus Mützel <markus.muetzel@gmx.de>
date Sat, 06 Feb 2021 11:14:13 +0100
parents 6dea3b384846
children 2a4998b97990
line wrap: on
line diff
--- a/configure.ac	Sat Feb 06 09:27:26 2021 -0500
+++ b/configure.ac	Sat Feb 06 11:14:13 2021 +0100
@@ -1067,14 +1067,14 @@
     AC_MSG_CHECKING([for required _WIN32_WINNT])
     AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
         #include <windows.h>
-        #if _WIN32_WINNT < 0x0403
+        #if _WIN32_WINNT < 0x0601
         #error "Wrong version"
         #endif
         ]], [])],
       [AC_MSG_RESULT([none])],
-      [AC_DEFINE(_WIN32_WINNT, 0x0403,
-        [Define to 0x0403 to access InitializeCriticalSectionAndSpinCount.])
-       AC_MSG_RESULT([0x0403])])
+      [AC_DEFINE(_WIN32_WINNT, 0x0601,
+        [Define to 0x0601 to access SetCurrentProcessExplicitAppUserModelID.])
+       AC_MSG_RESULT([0x0601])])
   ;;
 esac