diff configure.ac @ 29745:6c76819255cb

build: Avoid linking to wrapper for EnumProcessModules on Windows (bug #60746). * configure.ac: Since we require the Windows 7 API anyway, define PSAPI_VERSION=2 to use newer API and avoid additional wrapper.
author Markus Mützel <markus.muetzel@gmx.de>
date Mon, 07 Jun 2021 22:54:48 +0200
parents 07ecddf2174c
children 0916ffc997e6
line wrap: on
line diff
--- a/configure.ac	Tue Jun 08 14:32:21 2021 +0900
+++ b/configure.ac	Mon Jun 07 22:54:48 2021 +0200
@@ -1289,7 +1289,7 @@
 case $host_os in
   msdosmsvc | mingw*)
     AC_CHECK_HEADERS([psapi.h],
-      [LIBS="-lpsapi $LIBS" CPPFLAGS="-DPSAPI_VERSION=1 $CPPFLAGS"],
+      [CPPFLAGS="-DPSAPI_VERSION=2 $CPPFLAGS"],
       [AC_MSG_ERROR([Missing PSAPI required to build for Windows target.])],
       [#include <windows.h>])
   ;;