diff Makefile.am @ 30170:72adc88bc674

modernize bison rules * bootstrap.conf (gnulib_modules): Include bison in the list. * m4/acinclude.m4 (OCTAVE_PROG_BISON): Use gl_PROG_BISON to define BISON instead of AC_PROG_YACC to define YACC. Don't substitute WARN_YFLAGS. * libinterp/module.mk (%.cc %.h : %.yy): Assume we have bison, that it supports --defines=FILE and --output=FILE, and that we don't have to use ylwrap or work around weird y.tab.c and y.tab.h generated file names. * Makefile.am (AM_YFLAGS): Delete. (YACC): Define so that automake doesn't complain about seeing .yy source files without a definition of YACC in the Makefile. (AM_V_BISON, am__v_BISON_, am__v_BISON_0, am__v_BISON_1): New macros.
author John W. Eaton <jwe@octave.org>
date Tue, 14 Sep 2021 10:34:59 -0400
parents 7854d5752dd2
children f655202744be
line wrap: on
line diff
--- a/Makefile.am	Tue Sep 14 17:54:04 2021 +0900
+++ b/Makefile.am	Tue Sep 14 10:34:59 2021 -0400
@@ -42,7 +42,19 @@
 
 AM_LFLAGS = @LFLAGS@
 
-AM_YFLAGS = -dv ${WARN_YFLAGS}
+# Until modern Bison rules are handled by autoconf/automake.
+
+AM_V_BISON = $(am__v_BISON_$(V))
+am__v_BISON_ = $(am__v_BISON_$(AM_DEFAULT_VERBOSITY))
+am__v_BISON_0 = @echo "  BISON   " $@;
+am__v_BISON_1 =
+
+BISON = @BISON@
+BISONCOMPILE = $(BISON) $(AM_BISONFLAGS) $(BISONFLAGS)
+
+# Define YACC to pacify automake
+
+YACC = $(BISON)
 
 if AMCOND_LIB_VISIBILITY_FLAGS
   OCTAVE_VISIBILITY_FLAGS = ${CFLAG_VISIBILITY}