diff configure.ac @ 21818:7b0436d0f5be

rename maintainer-mode configure option to hd-id (bug #48101) * configure.ac: Rename --enable-maintainer-mode configure option to --enable-hg-id (enabled by default). * Makefile.am (DIST_HOOKS): New variable. (hg-id-dist-hook): Rename from maintainer-mode-dist-hook. (dist-hook): Depend on $(DIST_HOOKS). (all-local): Display HG ID for the build in summary message. (HG-ID): Attempt to make warnings more visible. Write "hg-id-disabled" to HG-ID file if --disable-hg-id configure option was used. Warn if HG-ID is "hg-id-disabled" and build is not done from Mercurial sources.
author John W. Eaton <jwe@octave.org>
date Fri, 03 Jun 2016 16:47:05 -0400
parents 418b6066e544
children 98f5dd2ff29a
line wrap: on
line diff
--- a/configure.ac	Fri Jun 03 11:45:21 2016 +0200
+++ b/configure.ac	Fri Jun 03 16:47:05 2016 -0400
@@ -285,13 +285,12 @@
 AC_DEFINE_UNQUOTED([SHELL_PATH], ["$SHELL_PATH"],
   [Define this to be the path to the shell command interpreter.])
 
-ENABLE_MAINTAINER_MODE=no
-AC_ARG_ENABLE([maintainer-mode],
-  [AS_HELP_STRING([--enable-maintainer-mode],
-    [enable maintainer mode features in build system])],
-  [if test "$enableval" = yes; then ENABLE_MAINTAINER_MODE=yes; fi], [])
-AM_CONDITIONAL([AMCOND_MAINTAINER_MODE],
-  [test $ENABLE_MAINTAINER_MODE = yes])
+ENABLE_HG_ID=yes
+AC_ARG_ENABLE([hg-id],
+  [AS_HELP_STRING([--disable-hg-id],
+    [disable embedding of hg id in libraries])],
+  [if test "$enableval" = no; then ENABLE_HG_ID=no; fi], [])
+AM_CONDITIONAL([AMCOND_ENABLE_HG_ID], [test $ENABLE_HG_ID = yes])
 
 ### Enable bounds checking on element references within Octave's array and
 ### matrix classes.  This slows down some operations a bit, so it is turned off